{"_id":"@damien-laurent/http-responses","_rev":"4-77e833ac08fcb973099c1058a9890833","name":"@damien-laurent/http-responses","dist-tags":{"latest":"1.1.2"},"versions":{"1.0.0":{"name":"@damien-laurent/http-responses","version":"1.0.0","description":"A simple library standardizing HTTP responses for an Express app.","main":"index.js","scripts":{"test":"jest"},"repository":{"type":"git","url":"git+https://gitlab.com/damien.laurentnauguet/http-responses.git"},"keywords":["Express","NodeJS","HTTP-responses"],"author":{"name":"damien.laurentnauguet"},"license":"ISC","bugs":{"url":"https://gitlab.com/damien.laurentnauguet/http-responses/issues"},"homepage":"https://gitlab.com/damien.laurentnauguet/http-responses#readme","_id":"@damien-laurent/http-responses@1.0.0","_nodeVersion":"10.17.0","_npmVersion":"6.11.3","dist":{"integrity":"sha512-ltk3Tf+gG8h0mYK432OeVyGAgJBeiE2Ph5P06rUuUsm6jiF+DZP0FeSzlVYr98xKNOT7eQab10A/XI5b+C/n4Q==","shasum":"ac371f9821bed799f7283f5ddad1773f261c0cfa","tarball":"https://registry.npmjs.org/@damien-laurent/http-responses/-/http-responses-1.0.0.tgz","fileCount":1,"unpackedSize":636,"npm-signature":"-----BEGIN PGP SIGNATURE-----\r\nVersion: OpenPGP.js v3.0.13\r\nComment: https://openpgpjs.org\r\n\r\nwsFcBAEBCAAQBQJf2jloCRA9TVsSAnZWagAAj9cQAJanHnPI9K8pg0W7q9EQ\ni66ckKJYi/sviOPey0it69oIa37+GzpAuXTenfvg86JbFdyDjN808qsblFfe\nkFhNPNCw0G9JWQ0LowPiZyKgKmvbmjp/o9dszWVbbdsg7BJyPtZH3Ni1DvQn\noEus6wPXARu0GHt9Wo92Dg4uR2kuw/I0ZgWf0HJmWba4+PmbAMfIKnycQnxv\n0CTbKBcOJVQmqu62S2eI7yl5G8WnG7hmrQ2ZuN+80NL0e6Sb4Bi5e1nQcUto\nsLiHx5m7CLB339jGPhFRfyVAVW/1X0L+Pv7TrazKxQF2vTe3R7ZI6Q8BJ4tV\nIiFzxCQACHMih2r0ThumjkcMhZWXtF5BgU4/6sRqGyT+MvjKfen1ax+RVeli\nLH3cc37BWDmzcR+1nBflRu5u3gkkUv0n1bTvIiZRWaQND60iN7MhcWsVXGJD\n+W3k1Ac4pXs7PtoUogzVUaP4Nb7YQH0CR+8H6VLgJbYjLs/1lTEnFXukopiL\nJA/7sjnpz2avDwjkIYDqK1tBNgmgNZM2XTKTn9Iyw50ojTCHT2Khb44pa8r0\nfkskU2yw1Lo/LLXw0F95OxC+nGUEIvvQTV9Mdg1fhSE0Dwctdc55Z1WcizZl\nfj50crwaaXReHfg8JX8fRaUWSH0HIACoqo0HQwhumYgjwtISqiu0Ph+k0kRu\nmJAn\r\n=jgkR\r\n-----END PGP SIGNATURE-----\r\n","signatures":[{"keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA","sig":"MEUCIGMg64KKRVxz+o+qdyL009ZmQHxIFPtkra1Keym0mw2iAiEAtqIVW/XSr5Vx5g38nLOpBJmX3geNeeZ3QM/e6Dd+GX8="}]},"_npmUser":{"name":"dlaurentn","email":"damien.laurentnauguet@gmail.com"},"directories":{},"maintainers":[{"name":"dlaurentn","email":"damien.laurentnauguet@gmail.com"}],"_npmOperationalInternal":{"host":"s3://npm-registry-packages","tmp":"tmp/http-responses_1.0.0_1608137063669_0.8816167685696883"},"_hasShrinkwrap":false},"1.1.0":{"name":"@damien-laurent/http-responses","description":"A simple library standardizing HTTP responses for an Express app.","version":"1.1.0","automaticPublish":"true","author":{"name":"damien.laurentnauguet"},"main":"index.js","scripts":{},"repository":{"type":"git","url":"git+https://gitlab.com/damien.laurentnauguet/http-responses.git"},"keywords":["Express","NodeJS","HTTP-responses"],"license":"MIT","bugs":{"url":"https://gitlab.com/damien.laurentnauguet/http-responses/issues"},"homepage":"https://gitlab.com/damien.laurentnauguet/http-responses#readme","dependencies":{"jest":"^26.4.2"},"devDependencies":{"jsdoc":"^3.6.6"},"gitHead":"85ff8aa432cf8b94dfe85b23a87cacc43fabfdaa","_id":"@damien-laurent/http-responses@1.1.0","_nodeVersion":"10.17.0","_npmVersion":"6.11.3","dist":{"integrity":"sha512-A7SbtLSRJ0cZXDVjtcc3FiNNIGygzA3+Hm4HkiC5OOiUQ63bDUU7DFxGWFOIOp3GTPQDBXe41mZIFeQu/JUhMQ==","shasum":"9d015830adb01856350a790a580c9dcf979b0ce8","tarball":"https://registry.npmjs.org/@damien-laurent/http-responses/-/http-responses-1.1.0.tgz","fileCount":75,"unpackedSize":36461,"npm-signature":"-----BEGIN PGP SIGNATURE-----\r\nVersion: OpenPGP.js v3.0.13\r\nComment: https://openpgpjs.org\r\n\r\nwsFcBAEBCAAQBQJgJszsCRA9TVsSAnZWagAAGYAP/RGpjZrDYthkcV2lvC9K\nJ8F2QgurcNX/7y3l0mS0ZdGTkUpggB05XvOR0XgwaJ/ZpWvnnCgZ0B3OcPry\n7LCoGBKFESDXMHjQ/U9ULu+ZONVrOKpyphfAt4Cic9Srbekx+AaGCgjp6XsL\nJ5BsOGF4fUbyVjplZ6MyiQJHZiMTlsh0xm4YUvvFSirkjxUx8dT29ISMHFiQ\nXw0arfjTH61ja1IVOk8+qDic2G41O6yGo6EvYwHol+vFWXI2nwPoY8FHu4VY\n4+9SNGIYgCXVqN+SQYagq7DPfMD40Q+LoyEWfkFaMewJM74NPEpLjFBpDWI/\nCAjG2gKmid1XjgckCFfdPq68ba4Fyl3aI42MyH0Eo5q78LDgzJOggksO2b6h\nG5pX+Y4Rg980qX7es6H5+CfLtBy9KYXursoSy2f+7z8afyltbEo1c1v4C4/O\nLArPb9caxIrkbEHIGzGGcqt3uSAIrLLklHqPGB7RMBurZzWKnLPBlCBiOh1R\nFKsg+mF4bbp9geIGZ9ip05dNKjczTLfCMDylASH1nGi3lMf98oxiGyisTFvu\n1zMtnCHFt/GOrg3SP2uYYnhhIHDnRTbbTBj1jQIFh6xvLGaV0M5BptpscAJw\n24SJiRE0ODqzOFIA7zOO0NTpKbwkCsfUARqsOjRXKz/nKln9Pvbm4L66nH7y\ni0V5\r\n=fKe/\r\n-----END PGP SIGNATURE-----\r\n","signatures":[{"keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA","sig":"MEQCIEnEf05xc1ReDx0KRho6D6vl6HITLxG7GLTNpYkFr3HtAiAB+EScoplGHCuV/9oToeaJuQqRngbVztGSV9phh48DKA=="}]},"_npmUser":{"name":"dlaurentn","email":"damien.laurentnauguet@gmail.com"},"directories":{},"maintainers":[{"name":"dlaurentn","email":"damien.laurentnauguet@gmail.com"}],"_npmOperationalInternal":{"host":"s3://npm-registry-packages","tmp":"tmp/http-responses_1.1.0_1613155563670_0.3472069850784274"},"_hasShrinkwrap":false},"1.1.1":{"name":"@damien-laurent/http-responses","description":"A simple library standardizing HTTP responses for an Express app.","version":"1.1.1","automaticPublish":"true","author":{"name":"damien.laurentnauguet"},"main":"index.js","scripts":{},"repository":{"type":"git","url":"git+https://gitlab.com/damien.laurentnauguet/http-responses.git"},"keywords":["Express","NodeJS","HTTP-responses"],"license":"MIT","bugs":{"url":"https://gitlab.com/damien.laurentnauguet/http-responses/issues"},"homepage":"https://gitlab.com/damien.laurentnauguet/http-responses#readme","dependencies":{"jest":"^26.4.2"},"devDependencies":{"jsdoc":"^3.6.6"},"gitHead":"67d569c5e6b8c69a063fc5be0ca20b56a6f951ba","_id":"@damien-laurent/http-responses@1.1.1","_nodeVersion":"10.22.0","_npmVersion":"6.14.6","dist":{"integrity":"sha512-ks/wW7e0T5zrrzK8C/nyreOapFXvjykOdJcYivkcXVhIfjyCSOgXq+BKIq0j8aoFeF2ZshgUfkfNqrewNxwuYQ==","shasum":"6a4962561e7aff0cd1468b60d6975319cc44bb21","tarball":"https://registry.npmjs.org/@damien-laurent/http-responses/-/http-responses-1.1.1.tgz","fileCount":75,"unpackedSize":36422,"npm-signature":"-----BEGIN PGP SIGNATURE-----\r\nVersion: OpenPGP.js v3.0.13\r\nComment: https://openpgpjs.org\r\n\r\nwsFcBAEBCAAQBQJgM7GHCRA9TVsSAnZWagAAHTkP+wcZ/yjdYWhg97DpFjOA\njX1T90dtqy61dCf1Omvih55ShAwvjrI/seg62oH2RcRctBwAWPcRlqPcn5EL\nAO3xyFuO1F97k3b1bTfwIHWuHF0CwNr2CRc3IqsZVlrkWQ4wE32dOqXjViL+\nS0X/Tm9KavT9D3HmZe/p8UEibO2KJaZMdLFxTCevUMlla/HR8BILXvIynV2f\nsWj1XQqvksIsbKNCFVz246xMpB3wK2qPnXlTCINzoUTXwGNq01jUPUa4PQ3i\nRCp4WIllU+hY7saQesMxy5y2d/4pRWfgMAYc8QGWR6jNpdvnsARzGHPr+QA7\nbf7Vd3lmU33YRyP9FCzpUfCT+N20GP4XPxDri90kunCPIw2IutcEfQMpGa+X\nQUxSCgO5W8JSONQ51eWJolsdavbPzv71u3Q0K1oLg12qdZL9kL1h/Zbfynrl\n9odXv/bFZHBubhpuPj9JXG21AS8Zho9bALvauzbm6n4kzJZ2H1yjE71EBQa8\naVlPt/7dWndI0S1zbJRGKYj6BZtB2tP8nfMan66qaasGCpNUtTkCdBMt1E3s\nqIkKIYg6gvxmteuEBArwzsz47dJZ0OHzOivRJEieLSBoP6bCEeq5dZVXPSJJ\njmQoAbqmBvHk9aIod/Bs6n+LviFChnpwP816Hpysej8R+6pFq7tEegGGYgMA\n4Kw+\r\n=Urfg\r\n-----END PGP SIGNATURE-----\r\n","signatures":[{"keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA","sig":"MEQCIGYrvixUn29gzJqUZFIVbeCR8D5AuhW4x6EL1zCIvynAAiBxi4rbhDHueoi9fqXBQ1TzKhuLEiLUJsvtPrxmAPSxcg=="}]},"_npmUser":{"name":"dlaurentn","email":"damien.laurentnauguet@gmail.com"},"directories":{},"maintainers":[{"name":"dlaurentn","email":"damien.laurentnauguet@gmail.com"}],"_npmOperationalInternal":{"host":"s3://npm-registry-packages","tmp":"tmp/http-responses_1.1.1_1614000519276_0.029366922127612938"},"_hasShrinkwrap":false},"1.1.2":{"name":"@damien-laurent/http-responses","description":"A simple library standardizing HTTP responses for an Express app.","version":"1.1.2","automaticPublish":"true","author":{"name":"damien.laurentnauguet"},"main":"index.js","scripts":{},"repository":{"type":"git","url":"git+https://gitlab.com/damien.laurentnauguet/http-responses.git"},"keywords":["Express","NodeJS","HTTP-responses"],"license":"MIT","bugs":{"url":"https://gitlab.com/damien.laurentnauguet/http-responses/issues"},"homepage":"https://gitlab.com/damien.laurentnauguet/http-responses#readme","dependencies":{"jest":"^26.4.2"},"devDependencies":{"jsdoc":"^3.6.6"},"gitHead":"c821ecd7a979374eed945021246276f63751dcc1","_id":"@damien-laurent/http-responses@1.1.2","_nodeVersion":"10.22.0","_npmVersion":"6.14.6","dist":{"integrity":"sha512-2qzOpJgJzQmmyCwRwOnswLaoP4NZHkD8NfP5jT62GHh+flE5VfE1EZqHUnBZtam2EXgPYk/d879ZcxGRLrh0mQ==","shasum":"7cf09df169e83cf76758517fa6704b5025bf00b1","tarball":"https://registry.npmjs.org/@damien-laurent/http-responses/-/http-responses-1.1.2.tgz","fileCount":75,"unpackedSize":36332,"npm-signature":"-----BEGIN PGP SIGNATURE-----\r\nVersion: OpenPGP.js v3.0.13\r\nComment: https://openpgpjs.org\r\n\r\nwsFcBAEBCAAQBQJgNO+DCRA9TVsSAnZWagAAaTQQAIm0aYVxBCF+NpYVco8c\nZ8endLXKZMUDxy8yJDgL/6K1Aqx6KFX0019K01CMTqRIx/UH8a1huesFS3GF\nCIU+Qf6nuCNpDNsXok4cKbeJ9eQ9HHvu2JL6qBfPBFP42S6O8vaTz4wMhfbA\nWAK2G/BtfAlN+RHZ1oPlz9LUJfXxUq/2DhzJvSKMMniPpvTI1+7dV6jVtLzG\nmn6cxZduYI6/1xpwp99dJfNRysFSI1QadHh2YOjWcCiUVa2etfw3r/d3BA1/\nhKSsXyn2Mh6zzmYFATED0dOK0B1YvaMXbQaswk13SZgr3IfvsiBczJdQ/omg\nDahuFxdghaqW4XAGb9L6Xah/rVAYsrPYywcfOe3LHY/qb0mXCsAIwk2NIir9\nrwnuwXE90+Nl/LKDrhUgN2uUDIAC9hhUq7ZgYdyr0ZO7DGOAWRnxTCebMfn+\np87GRgtPmwaLI68Qa8VWNIyWDxLFe+CrefLbV8Tn19olEAp9KwRK42kDzqbv\nE3NEhurv/t/hpshA08jOZympOG/ZaOURA6JcssJyFy1Dv9qpmwUSL3BNEOcP\nKKv4WiG3bFAku8Ke5N+qPjGxfYFbx5yBMioOJn3nRZ9O4lLl+SnKfZnC5I7V\nJVnKT+HKIKJy83hIBqbut6LGFmJQHusyTgx/B9Km2ZxgY6oRr+WgVPr+/6fq\nyKHV\r\n=E93Q\r\n-----END PGP SIGNATURE-----\r\n","signatures":[{"keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA","sig":"MEQCIGy3ejhgWxy5G1y2FQRzCQSVzTRbv4ba1Rm8GbI0CWf5AiA7tBgVDd+/+UTj32Iwhc4skKBM+rAT8zzmn103oDG2rA=="}]},"_npmUser":{"name":"dlaurentn","email":"damien.laurentnauguet@gmail.com"},"directories":{},"maintainers":[{"name":"dlaurentn","email":"damien.laurentnauguet@gmail.com"}],"_npmOperationalInternal":{"host":"s3://npm-registry-packages","tmp":"tmp/http-responses_1.1.2_1614081922776_0.2165574771690384"},"_hasShrinkwrap":false}},"time":{"created":"2020-12-16T16:44:23.446Z","1.0.0":"2020-12-16T16:44:23.797Z","modified":"2022-04-05T02:38:45.791Z","1.1.0":"2021-02-12T18:46:03.819Z","1.1.1":"2021-02-22T13:28:39.429Z","1.1.2":"2021-02-23T12:05:22.922Z"},"maintainers":[{"name":"dlaurentn","email":"damien.laurentnauguet@gmail.com"}],"description":"A simple library standardizing HTTP responses for an Express app.","homepage":"https://gitlab.com/damien.laurentnauguet/http-responses#readme","keywords":["Express","NodeJS","HTTP-responses"],"repository":{"type":"git","url":"git+https://gitlab.com/damien.laurentnauguet/http-responses.git"},"author":{"name":"damien.laurentnauguet"},"bugs":{"url":"https://gitlab.com/damien.laurentnauguet/http-responses/issues"},"license":"MIT","readme":"# HTTP RESPONSES\n\nA simple library standardizing HTTP responses for an Express app.\n\n\n## Installation\n\nThis is a [Node.js](https://nodejs.org/en/) module available through the\n[npm registry](https://www.npmjs.com/). Installation is done using the\n[`npm install` command](https://docs.npmjs.com/getting-started/installing-npm-packages-locally):\n\n```sh\n$ npm install express-requests-logger\n```\n\n## Usage\n\n```js\n// Works with objects\nres.ok({ key: \"value\" });\n// => 200 - { key: \"value\" }\n\n// Works with strings\nres.forbidden(\"You should not be here\");\n// => 403 - { message: \"You should not be here\" }\n\n// Works with errors\nres.internalServerError(new Error(\"This is an error message\"))\n// => 500 - { message: \"This is an error message\" }\n```\n\n## Examples\n\nAll examples [here](https://gitlab.com/damien.laurentnauguet/http-responses/examples).\n\n### Use all available responses\n\n```js\nconst httpResponses = require(\"@damien-laurent/http-responses\");\nconst express = require(\"express\");\nconst router = express.Router();\n\n(async () => {\n\ttry {\n\t\t// Declare express app\n\t\tconst application = express();\n\n\t\t// Since express v4.16.0, express.json() replaces bodyparser.json()\n\t\tapplication.use(express.json());\n\n\t\t// Register all HTTP responses\n\t\tapplication.use(httpResponses.all());\n\n\t\t// Add a route\n\t\trouter.get(\"/\", (req, res) => res.ok({ key: \"Great, it works with strings\" }));\n\t\trouter.post(\"/\", (req, res) => res.forbidden(\"The access to this section is restricted.\"));\n\n\t\t// Routes: initialize router\n\t\tapplication.use(\"/\", router);\n\n\t\t// Run application\n\t\tawait application.listen(3000);\n\t}\n\tcatch (error) {\n\t\tconsole.error(error.message);\n\t}\n})();\n```\n\n### Select some of available responses\n\n```js\nconst httpResponses = require(\"@damien-laurent/http-responses\");\nconst express = require(\"express\");\nconst router = express.Router();\n\n(async () => {\n\ttry {\n\t\t// Declare express app\n\t\tconst application = express();\n\n\t\t// Since express v4.16.0, express.json() replaces bodyparser.json()\n\t\tapplication.use(express.json());\n\n\t\t// Register all HTTP responses\n\t\tapplication.use(httpResponses.select([\"success.ok\"]));\n\n\t\t// Add a route\n\t\trouter.get(\"/\", (req, res) => res.ok({ key: \"Great, it works with strings\" }));\n\n\t\t// Routes: initialize router\n\t\tapplication.use(\"/\", router);\n\n\t\t// Run application\n\t\tawait application.listen(3000);\n\t}\n\tcatch (error) {\n\t\tconsole.error(error.message);\n\t}\n})();\n```\n\n### Create a custom response\n\n```js\nconst httpResponses = require(\"@damien-laurent/http-responses\");\nconst express = require(\"express\");\nconst router = express.Router();\n\n(async () => {\n\ttry {\n\t\t// Declare express app\n\t\tconst application = express();\n\n\t\t// Since express v4.16.0, express.json() replaces bodyparser.json()\n\t\tapplication.use(express.json());\n\n\t\t// Create a custom HTTP response\n\t\tconst customHttpResponse = httpResponses.custom(\"serverError\", 500, console.log);\n\n\t\t// Register it to application\n\t\tapplication.use(customHttpResponse);\n\n\t\t// Add a route\n\t\trouter.get(\"/\", (req, res) => {\n\t\t\ttry {\n\t\t\t\tthrow new Error(\"Aie aie\");\n\t\t\t}\n\t\t\tcatch (error) {\n\t\t\t\treturn res.serverError(error);\n\t\t\t}\n\t\t});\n\n\t\t// Routes: initialize router\n\t\tapplication.use(\"/\", router);\n\n\t\t// Run application\n\t\tawait application.listen(3000);\n\t}\n\tcatch (error) {\n\t\tconsole.error(error.message);\n\t}\n})();\n```\n\n## Available responses\n\nBasically, any response defined [here](https://en.wikipedia.org/wiki/List_of_HTTP_status_codes) is available.\n\n### 2xx success\n\n```js\n// 200 | OK\nres.ok(response payload);\n\n// 201 | Created\nres.created(response payload);\n\n// 202 | Accepted\nres.accepted(response payload);\n\n// 203 | Non-Authoritative Information (since HTTP/1.1)\nres.nonAuthoritativeInformation(response payload);\n\n// 204 | No Content\nres.noContent(response payload);\n\n// 205 | Reset Content\nres.resetContent(response payload);\n\n// 206 | Partial Content (RFC 7233)\nres.partialContent(response payload);\n\n// 207 | Multi-Status (WebDAV; RFC 4918)\nres.multiStatus(response payload);\n\n// 208 | Already Reported (WebDAV; RFC 5842)\nres.alreadyReported(response payload);\n\n// 226 | IM Used (RFC 3229)\nres.imUsed(response payload);\n```\n\n\n### 3xx redirection\n```js\n// 300 | Multiple Choices\nres.multipleChoices(response payload);\n\n// 301 | Moved Permanently\nres.movedPermanently(response payload);\n\n// 302 | Found (Previously \"Moved temporarily\")\nres.found(response payload);\n\n// 303 | See Other (since HTTP/1.1)\nres.seeOther(response payload);\n\n// 304 | Not Modified (RFC 7232)\nres.notModified(response payload);\n\n// 305 | Use Proxy (since HTTP/1.1)\nres.useProxy(response payload);\n\n// 306 | Switch Proxy\nres.switchProxy(response payload);\n\n// 307 | Temporary Redirect (since HTTP/1.1)\nres.temporaryRedirect(response payload);\n\n// 308 | Permanent Redirect (RFC 7538)\nres.permanentRedirect(response payload);\n```\n\n\n### 4xx client errors\n\n```js\n// 400 | Bad Request\nres.badRequest(response payload);\n\n// 401 | Unauthorized (RFC 7235)\nres.unauthorized(response payload);\n\n// 402 | Payment Required\nres.paymentRequired(response payload);\n\n// 403 | Forbidden\nres.forbidden(response payload);\n\n// 404 | Not Found\nres.notFound(response payload);\n\n// 405 | Method Not Allowed\nres.methodNotAllowed(response payload);\n\n// 406 | Not Acceptable\nres.notAcceptable(response payload);\n\n// 407 | Proxy Authentication Required (RFC 7235)\nres.proxyAuthenticationRequired(response payload);\n\n// 408 | Request Timeout\nres.requestTimeout(response payload);\n\n// 409 | Conflict\nres.conflict(response payload);\n\n// 410 | Gone\nres.gone(response payload);\n\n// 411 | Length Required\nres.lengthRequired(response payload);\n\n// 412 | Precondition Failed (RFC 7232)\nres.preconditionFailed(response payload);\n\n// 413 | Payload Too Large (RFC 7231)\nres.payloadTooLarge(response payload);\n\n// 414 | URI Too Long (RFC 7231)\nres.uriTooLong(response payload);\n\n// 415 | Unsupported Media Type (RFC 7231)\nres.unsupportedMediaType(response payload);\n\n// 416 | Range Not Satisfiable (RFC 7233)\nres.rangeNotSatisfiable(response payload);\n\n// 417 | Expectation Failed\nres.expectationFailed(response payload);\n\n// 418 | I'm a teapot (RFC 2324, RFC 7168)\nres.imATeapot(response payload);\n\n// 421 | Misdirected Request (RFC 7540)\nres.misdirectedRequest(response payload);\n\n// 422 | Unprocessable Entity (WebDAV; RFC 4918)\nres.unprocessableEntity(response payload);\n\n// 423 | Locked (WebDAV; RFC 4918)\nres.locked(response payload);\n\n// 424 | Failed Dependency (WebDAV; RFC 4918)\nres.failedDependency(response payload);\n\n// 425 | Too Early (RFC 8470)\nres.tooEarly(response payload);\n\n// 426 | Upgrade Required\nres.upgradeRequired(response payload);\n\n// 428 | Precondition Required (RFC 6585)\nres.preconditionRequired(response payload);\n\n// 429 | Too Many Requests (RFC 6585)\nres.tooManyRequests(response payload);\n\n// 431 | Request Header Fields Too Large (RFC 6585)\nres.requestHeaderFieldsTooLarge(response payload);\n\n// 451 | Unavailable For Legal Reasons (RFC 7725)\nres.unavailableForLegalReasons(response payload);\n```\n\n### 5xx server errors\n\n```js\n// 500 | Internal Server Error\nres.internalServerError(response payload);\n\n// 501 | Not Implemented\nres.notImplemented(response payload);\n\n// 502 | Bad Gateway\nres.badGateway(response payload);\n\n// 503 | Service Unavailable\nres.serviceUnavailable(response payload);\n\n// 504 | Gateway Timeout\nres.gatewayTimeout(response payload);\n\n// 505 | HTTP Version Not Supported\nres.httpVersionNotSupported(response payload);\n\n// 506 | Variant Also Negotiates (RFC 2295)\nres.variantAlsoNegotiates(response payload);\n\n// 507 | Insufficient Storage (WebDAV; RFC 4918)\nres.insufficientStorage(response payload);\n\n// 508 | Loop Detected (WebDAV; RFC 5842)\nres.loopDetected(response payload);\n\n// 510 | Not Extended (RFC 2774)\nres.notExtended(response payload);\n\n// 511 | Network Authentication Required (RFC 6585)\nres.networkAuthenticationRequired(response payload);\n```\n\n## Licence\n\nMIT\n","readmeFilename":"README.md"}