{"_id":"abnf","_rev":"32-8d2502a2cf9d4613a08472abdaf7b7f1","name":"abnf","dist-tags":{"latest":"5.0.4"},"versions":{"0.0.0":{"name":"abnf","version":"0.0.0","author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@0.0.0","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"homepage":"https://github.com/hildjj/node-abnf","bin":{"ast":"bin/ast","check_refs":"bin/check_refs"},"dist":{"shasum":"5176fbfcc203f939b50ca4ec8985b29b98867bff","tarball":"https://registry.npmjs.org/abnf/-/abnf-0.0.0.tgz","integrity":"sha512-V8mbLmwYsh3EQJu6GNZdUeu0gC7C6dMjWkymAVp/dheXw7rUE12rJrGgPHRU2RH3HgTkeHTCbCiajamPhu2dTQ==","signatures":[{"sig":"MEQCIEQIZQbSnCzq9LbqiQgr4OP0m21Y1mbI2gbkYAfsmoRBAiBzLUJTRz0A1BvB4mWUttpSr/wEAG6kF5iMgxCuYtrJxg==","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}]},"main":"lib/abnf","engines":{"node":"~0.6.18"},"_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"1.1.21","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 4234.","directories":{"bin":"./bin","lib":"./lib"},"_nodeVersion":"v0.6.18","dependencies":{"reparse":"~0.1.2"},"_defaultsLoaded":true,"devDependencies":{},"_engineSupported":true,"optionalDependencies":{}},"0.0.1":{"name":"abnf","version":"0.0.1","author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@0.0.1","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"homepage":"https://github.com/hildjj/node-abnf","bin":{"ast":"bin/ast","check_refs":"bin/check_refs"},"dist":{"shasum":"d6f5eb23a7af3bcc84927ccd708aa204f36d3d6b","tarball":"https://registry.npmjs.org/abnf/-/abnf-0.0.1.tgz","integrity":"sha512-U5JGCDv2PUWfkSq5mwdnNDDKxPW5ncNNQMSWHzENVdRjJ00RTgFiJfbIrVvt9cPNkeWp2xkXbtaa3bwPN85XvA==","signatures":[{"sig":"MEUCIA1JkyXBdyWz2dxF+MNMIdZHgNl4PTiv2afxOqkA+GBlAiEA/GC8Ew4XsON+McmHS+f4LjGUa0IpGpQuJ3mio3EfsHE=","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}]},"main":"lib/abnf","engines":{"node":"~0.6.18"},"_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"1.1.21","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{"bin":"./bin","lib":"./lib"},"_nodeVersion":"v0.6.18","dependencies":{"reparse":"~0.1.2"},"_defaultsLoaded":true,"devDependencies":{},"_engineSupported":true,"optionalDependencies":{}},"0.0.2":{"name":"abnf","version":"0.0.2","author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@0.0.2","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"homepage":"https://github.com/hildjj/node-abnf","bin":{"ast":"bin/ast","check_refs":"bin/check_refs"},"dist":{"shasum":"98061558c5fca751b1f8676258de43937f8bf36b","tarball":"https://registry.npmjs.org/abnf/-/abnf-0.0.2.tgz","integrity":"sha512-y2wcJPOWjj75mebDE/39TDXWEDMQtgZor4Y0bYrF3Z67NVrJWobP6rpB92Xe+VcS1hsa4Yu76tZEqgxLFXOuZg==","signatures":[{"sig":"MEQCIHFlDQoOkk99kXUwuICQdp9olGUbFizSNA9zVGUW782CAiA7QBq5LJpzEh3q/+vmD/NkNUHDfKk6ZfxdtU/C9D9WrQ==","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}]},"main":"lib/abnf","engines":{"node":"~0.6.18"},"_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"1.1.21","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{"bin":"./bin","lib":"./lib"},"_nodeVersion":"v0.6.18","dependencies":{"reparse":"~0.1.2"},"_defaultsLoaded":true,"devDependencies":{},"_engineSupported":true,"optionalDependencies":{}},"0.0.3":{"name":"abnf","version":"0.0.3","author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@0.0.3","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"homepage":"https://github.com/hildjj/node-abnf","bin":{"ast":"bin/ast","check_refs":"bin/check_refs"},"dist":{"shasum":"d862989e08b37957ed23270afb705bb3c70670ef","tarball":"https://registry.npmjs.org/abnf/-/abnf-0.0.3.tgz","integrity":"sha512-8QhOYdLa4HPyKkzKhLP2HQfO50ghlSiseqQ9i9cmWcgXw9sXCTN/oN57Phcup9wP8/84+SS+8KxEH8uVDEQHzA==","signatures":[{"sig":"MEYCIQD5LBhm0uSq9T55En6b7c8yNGAxV923cOnkoD/KstwFAwIhAPlpQ+04rjPaWYSgOt0KP9cMDWgiUHJd88pWAoYUxSVY","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}]},"main":"lib/abnf","engines":{"node":"~0.8.1"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{"bin":"./bin","lib":"./lib"},"dependencies":{"reparse":"~0.1.2"},"devDependencies":{},"optionalDependencies":{}},"0.0.4":{"name":"abnf","version":"0.0.4","author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@0.0.4","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"ast":"bin/ast","check_refs":"bin/check_refs"},"dist":{"shasum":"e2352f98491d14dfdeb64e5088fae4a269583d48","tarball":"https://registry.npmjs.org/abnf/-/abnf-0.0.4.tgz","integrity":"sha512-2V0wZK+34gd2vdd1zYzBHjFE8FdRenNU+4kh5bQgF2bIIk14opapLlhyRor1YzcFKoDEq8dO8wH8GfScd64s4w==","signatures":[{"sig":"MEUCIHKgSn9bSEt+vvh8FZj9DOiyLspmkBZHy4vCbel0FtUlAiEAh41GvLeqDK2XHcpS3vUhbqJ9rtDZkuvalOwfsWc0TYM=","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}]},"main":"lib/abnf","_from":".","engines":{"node":"~0.10.10"},"_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"1.2.25","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{"bin":"./bin","lib":"./lib"},"dependencies":{"reparse":"~0.1.2"},"readmeFilename":"README.md","devDependencies":{},"optionalDependencies":{}},"0.0.5":{"name":"abnf","version":"0.0.5","author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@0.0.5","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast","abnf_check":"bin/abnf_check"},"dist":{"shasum":"7ef249c3a48ca199451c6bbc2dab93b3fee7506c","tarball":"https://registry.npmjs.org/abnf/-/abnf-0.0.5.tgz","integrity":"sha512-D3GR0bRJWWWhm3LKE8JaLNGW/zsgt6jIDfmdzgFclWogpBcz0n0dur7Q7OG6wDhwMc+K7uEDtouw3BkEvObR7Q==","signatures":[{"sig":"MEQCICBjo0k3DdicSR5XoEzQEgGDS81sfMYf4WX+zMVgCnZfAiAbOIKKV33oysiWoszlXWeBSZv+ZJvqXppnhilqLYFjzw==","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}]},"main":"lib/abnf","_from":".","engines":{"node":"~0.10.10"},"_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"1.2.25","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{"bin":"./bin","lib":"./lib"},"dependencies":{"reparse":"~0.1.2"},"readmeFilename":"README.md","devDependencies":{},"optionalDependencies":{}},"1.0.0":{"name":"abnf","version":"1.0.0","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@1.0.0","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js"},"dist":{"shasum":"dd07655bc133c2c3c3a88dfeeb758df99263d9d7","tarball":"https://registry.npmjs.org/abnf/-/abnf-1.0.0.tgz","fileCount":11,"integrity":"sha512-p6/Ft/cTPiFtA98Yyb3IR64ZIaH9MZKOYmDJLH0JSl7U/GYtp+ahj8XBLY677Bwg6+gT9e5nR4h06q2jVocKmg==","signatures":[{"sig":"MEYCIQD/59jAFWh/lfHhelBIl3Lk+bS4J8QKtOZ0/F7+MowFWQIhALA1mqsanC1ao6gHsN0yVjuJgK/CLlDgkM0OcHQ38bKz","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"unpackedSize":83727,"npm-signature":"-----BEGIN PGP SIGNATURE-----\r\nVersion: OpenPGP.js v4.10.10\r\nComment: https://openpgpjs.org\r\n\r\nwsFzBAEBCAAGBQJkIdBSACEJED1NWxICdlZqFiEECWMYAoorWMhJKdjhPU1b\r\nEgJ2VmoUAw//ZwdP0B6RaZ0CFdOssnFlwgPRnUAOlJOLTQpcMkpktyfnE7+X\r\njhvbMH4HxG25JQH/T6fzo07SkusIMBBD7VRavBgzCKzhachaqt6xiaVqpecY\r\nKKWiOh1pjDADs3XdydSDnku8Lyb9hFnUNHnd0KbrzZihkoCLjwLzWUuIdblZ\r\n7fWYgtZAPM2yXk1ODvog5wwvxt7Anwl83Dfs0fIEkSUHPQ+ZzZjTZ/7Q71Tj\r\nT1LEnZFsujuQKWaY1UnQ3R/zCnAxPba63WWlF4Jkf8jS3M1mB/7pB6sq/UI+\r\noIlUibw9jTMh/nnmu9GB8mxyLrTy6pH7FOzryg5peTvia3BvEaMSoVsi+p4t\r\nK1Tr7iZphsIWxwmguhg/Qk2znD4TZZOEgyxGo7Si/pBENyquSjUZ+Ra15Osd\r\nDAxSFVtWR7sbn+GQzCPHo60qH4V+6rFlJMqNnys2xba/adN+Rt/H44zViu6M\r\nxEFHcuvl3jxZ2+iZqpKVV8qrRpNy1Ja9xTUZaw68bymY4kqogXJnO1OLZb9o\r\nU04JqNsNN/Q9PmFPdEQTq7o/CKT+X0z3qUkIC0ItbUCFg26FiZFwK1E4l2fX\r\nEBNfeDcvmD+xwyI3EadiB//IPh39Bq8kGbp03ewPZNLuW+FiL3aS4bdNvA5r\r\ndfL91kZWE/HfnXJBVkcRpDtuoM02w/Hezo4=\r\n=HspM\r\n-----END PGP SIGNATURE-----\r\n"},"main":"lib/abnf","type":"module","engines":{"node":">=14"},"gitHead":"4d16a6b419155112eb35c7a8fee6da82331a707d","scripts":{"lint":"eslint . --ext js && eslint bin/*","test":"ava","build":"peggy --format es lib/abnfp.peggy","pretest":"npm run build","coverage":"c8 -r lcov ava"},"_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"9.6.2","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"19.8.1","dependencies":{"peggy":"^3.0.2","commander":"^10.0.0"},"_hasShrinkwrap":false,"devDependencies":{"c8":"7.13.0","ava":"5.2.0","eslint":"^8.36.0","typescript":"^5.0.2","@peggyjs/eslint-config":"^3.0.1","@typescript-eslint/parser":"^5.56.0","@typescript-eslint/eslint-plugin":"^5.56.0"},"_npmOperationalInternal":{"tmp":"tmp/abnf_1.0.0_1679937617964_0.2817526401957757","host":"s3://npm-registry-packages"}},"2.0.0":{"name":"abnf","version":"2.0.0","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@2.0.0","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js"},"dist":{"shasum":"809deaa8ba842fc37cd3321323f2b726a13d2a64","tarball":"https://registry.npmjs.org/abnf/-/abnf-2.0.0.tgz","fileCount":11,"integrity":"sha512-fiqyukBFG/5/J0W02Drsa15nCjJapNZLN9JS1mOhpN7AWKbQ9I46xiaRQtLC5dUOjnds7yqnhWSRuxme2j7lWQ==","signatures":[{"sig":"MEYCIQDIDSq3jn0kmsxJwzKonJ/3Yy1r06oRe4/nG7Y4cbplQgIhAK8AH7wLoJ7fm89pfoUbGGiiU4iOtJBU7EF3p/vuEnJi","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"unpackedSize":83942},"main":"lib/abnf","pnpm":{"overrides":{"semver":">=7.5.3","word-wrap":"npm:@aashutoshrathi/word-wrap"}},"type":"module","engines":{"node":">=16"},"gitHead":"36aa27b36c9385a11b39374094772670dbb664d7","scripts":{"lint":"eslint . --ext js && eslint bin/*","test":"ava","build":"peggy --format es lib/abnfp.peggy","pretest":"npm run build","coverage":"c8 -r lcov ava"},"_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"overrides":{"semver":">=7.5.3","word-wrap":"npm:@aashutoshrathi/word-wrap"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"9.7.2","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"20.3.1","dependencies":{"peggy":"^3.0.2","commander":"^11.0.0"},"_hasShrinkwrap":false,"devDependencies":{"c8":"8.0.0","ava":"5.3.1","eslint":"^8.43.0","typescript":"^5.1.6","@peggyjs/eslint-config":"^3.0.2","@typescript-eslint/parser":"^5.60.1","@typescript-eslint/eslint-plugin":"^5.60.1"},"_npmOperationalInternal":{"tmp":"tmp/abnf_2.0.0_1688144832345_0.5364175658023458","host":"s3://npm-registry-packages"}},"3.0.0":{"name":"abnf","version":"3.0.0","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@3.0.0","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js"},"dist":{"shasum":"300e9631aa940e82c27fb72df9a7326ef6c0ed67","tarball":"https://registry.npmjs.org/abnf/-/abnf-3.0.0.tgz","fileCount":11,"integrity":"sha512-4tiZ4VaGTkB08fIcrk1JehLgO0OYwU/836j464YLYSxhSZo0wPmaZIM6W+LrLjmIKdxKvPo9K30mDJ4wmTS+Gg==","signatures":[{"sig":"MEYCIQDL/vQD0S3hmTS+JiWRiK/3cBOXU5n8KXMLrHFpSuohLAIhAOTJL68SRGc1ObAFBTrF4aMV7rw+VHlxTKTjlet54sLB","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"unpackedSize":85805},"main":"lib/abnf","type":"module","engines":{"node":">=18"},"gitHead":"8e9558f3ec4aa5542ccd19a29a6e8ed1145e42e7","scripts":{"lint":"eslint .","test":"ava","build":"peggy --format es lib/abnfp.peggy","pretest":"npm run build","coverage":"c8 ava","precoverage":"npm run build"},"_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.5.2","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"21.7.3","dependencies":{"peggy":"^4.0.2","commander":"^12.0.0"},"_hasShrinkwrap":false,"packageManager":"pnpm@9.0.2+sha256.d6fc013639b81658ff175829ebb9435bcb89eff206769e460fd3ae27c2054df6","devDependencies":{"c8":"9.1.0","ava":"6.1.2","eslint":"^8.57.0","typescript":"^5.4.5","@peggyjs/eslint-config":"^3.2.4","@typescript-eslint/parser":"^7.7.0","@typescript-eslint/eslint-plugin":"^7.7.0"},"_npmOperationalInternal":{"tmp":"tmp/abnf_3.0.0_1713543864975_0.4699477552992961","host":"s3://npm-registry-packages"}},"3.0.1":{"name":"abnf","version":"3.0.1","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@3.0.1","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"e3af2852aa2c03213e6e2fc6ccbd33890e4ac741","tarball":"https://registry.npmjs.org/abnf/-/abnf-3.0.1.tgz","fileCount":11,"integrity":"sha512-GVWHXGGPAyGxciYr3fq963iqRg8K1YQQZwBJRNeHIkUUIfKuqM3BGYFLp4FPVb3SfrjJmkkCUN/Yw7d2bob1lQ==","signatures":[{"sig":"MEUCIQCq7F5JTWXptkfQPPvNG3Hz7LWqP0r896h9QHnMQBaWzAIgasG4Ff3nHYj24KJnYuGqsMXPIrCzqqVKEX0v4ZatIfA=","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"unpackedSize":85962},"main":"lib/abnf","type":"module","engines":{"node":">=18"},"gitHead":"60afbf90081117cf0fb0691a99ff8a2c62324562","scripts":{"lint":"eslint .","test":"ava","build":"peggy --format es lib/abnfp.peggy","pretest":"npm run build","coverage":"c8 ava","precoverage":"npm run build"},"_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.7.0","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.1.0","dependencies":{"peggy":"^4.0.2","commander":"^12.0.0"},"_hasShrinkwrap":false,"packageManager":"pnpm@9.1.0","devDependencies":{"c8":"9.1.0","ava":"6.1.3","eslint":"^8.57.0","typescript":"^5.4.5","@peggyjs/coverage":"1.1.0","@peggyjs/eslint-config":"^3.2.4","@typescript-eslint/parser":"^7.8.0","@typescript-eslint/eslint-plugin":"^7.8.0"},"_npmOperationalInternal":{"tmp":"tmp/abnf_3.0.1_1715530063758_0.8022809880586388","host":"s3://npm-registry-packages"}},"4.0.1":{"name":"abnf","version":"4.0.1","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@4.0.1","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"11db24f33a22d354cd130fe588875b26327636f0","tarball":"https://registry.npmjs.org/abnf/-/abnf-4.0.1.tgz","fileCount":11,"integrity":"sha512-g7Ru4ZvfpP24OZXegxAhNPU2slM8cgNNVAL7KqAbyCv8gHLHQ9TmcfsMgA0asZ33PeM4yCCKHx50rnHJr7z5Mg==","signatures":[{"sig":"MEQCIFsY4r9yvdnBw/HS4adm1R+B1CvgmSDS4zDFW3lyTN23AiB5VkclbRDiRreZm3CK6nXRdaaXs0wvrr+5A4QKak8Erw==","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@4.0.1","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":89434},"main":"lib/abnf.js","type":"module","engines":{"node":">=18"},"gitHead":"f62eee3457c9ad2fbbbf6a0f37e22a2c85a017e5","scripts":{"ci":"npm run coverage && npm run lint","lint":"eslint .","test":"ava","build":"peggy --format es lib/abnfp.peggy","pretest":"npm run build","coverage":"c8 ava","precoverage":"npm run build"},"_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.8.2","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.7.0","dependencies":{"peggy":"^4.0.3","commander":"^12.1.0"},"_hasShrinkwrap":false,"packageManager":"pnpm@9.9.0","devDependencies":{"c8":"10.1.2","ava":"6.1.3","eslint":"^9.9.1","typescript":"^5.5.4","@peggyjs/coverage":"1.2.0","@peggyjs/eslint-config":"^4.0.4","@typescript-eslint/parser":"^8.3.0","@typescript-eslint/eslint-plugin":"^8.3.0"},"_npmOperationalInternal":{"tmp":"tmp/abnf_4.0.1_1724949269176_0.7060260617710765","host":"s3://npm-registry-packages"}},"4.0.2":{"name":"abnf","version":"4.0.2","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@4.0.2","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"3c54427ef7ca377acc6d96e4e41fbb553b7d747e","tarball":"https://registry.npmjs.org/abnf/-/abnf-4.0.2.tgz","fileCount":13,"integrity":"sha512-Arb16Gi7jRa7osbI8bP7jR4qw4xQrlGx2N0eFI9x5JPZJIvl30IBbBomlWUbvtmovmL2a8h5g9mk7xM5HWRXBw==","signatures":[{"sig":"MEQCICFApYvByKJAiqskZNCj37QoLV2+mG9P1VWmLxKmrnAOAiAHGAqhwxpUa0fSTyNMMMwdj8hTS1VQWrCnulQt731WyQ==","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@4.0.2","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":94867},"main":"lib/abnf.js","type":"module","engines":{"node":">=18"},"gitHead":"5336c909b2d7b81b4c1341c59b73e82143fc31a4","_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.9.0","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.10.0","dependencies":{"peggy":"^4.1.1","commander":"^12.1.0"},"_hasShrinkwrap":false,"_npmOperationalInternal":{"tmp":"tmp/abnf_4.0.2_1731001505719_0.7174673343941533","host":"s3://npm-registry-packages"}},"4.1.0":{"name":"abnf","version":"4.1.0","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@4.1.0","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"441be6a4eee6234dbc805b47b817ccb1b4e9f0f2","tarball":"https://registry.npmjs.org/abnf/-/abnf-4.1.0.tgz","fileCount":13,"integrity":"sha512-CczpVYr8hLcR/15041m/k+wsKnvFV43NrJZKEqJkuGPTwaSJPqJBCSvuiFaywcKBcPx/XtuNHXhpbV2fc6ZgMg==","signatures":[{"sig":"MEQCIEKyxkGPMH+r+yQqpNGaRR1NgQ24XJckE3m0qrKcR2M7AiAHxb2jzakGTGRZiyPm9twbt6mN5RwB3SsR0WdlRbT5aQ==","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@4.1.0","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":95180},"main":"lib/abnf.js","pnpm":{"overrides":{"braces":"^3.0.3","micromatch":"^4.0.8"}},"type":"module","engines":{"node":">=18"},"gitHead":"8104e1405a39928c76bf6f5aeb281449df15995a","_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.9.0","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.10.0","dependencies":{"peggy":"^4.1.1","commander":"^12.1.0"},"_hasShrinkwrap":false,"_npmOperationalInternal":{"tmp":"tmp/abnf_4.1.0_1731165112246_0.7560575176867974","host":"s3://npm-registry-packages"}},"4.2.0":{"name":"abnf","version":"4.2.0","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@4.2.0","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"dc4b3b16647b3e1c49d682907058eebda40c9dc7","tarball":"https://registry.npmjs.org/abnf/-/abnf-4.2.0.tgz","fileCount":13,"integrity":"sha512-CsnwfeSEaizCtlqAjS5c3vAOeQbbS5hwt1W2G9wo7lxgzR8VeVZHa087okejIrtdJhCjVIuLx3bog2v2O/pNsQ==","signatures":[{"sig":"MEQCID/dz0j32lWCsxGfMpN5XhbKjNR/jRGmubdSeaDcatEtAiAUAt9P157kT1r2+4eC0Igg15W1RxXTlawQ4AMxT/yWyw==","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@4.2.0","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":96278},"main":"lib/abnf.js","pnpm":{"overrides":{"braces":"^3.0.3","micromatch":"^4.0.8"}},"type":"module","engines":{"node":">=18"},"gitHead":"d506ac407c24ee06e1e460b4a0f97005d5a119c8","_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.9.0","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.10.0","dependencies":{"peggy":"^4.1.1","commander":"^12.1.0"},"_hasShrinkwrap":false,"_npmOperationalInternal":{"tmp":"tmp/abnf_4.2.0_1731447975891_0.012777507279489342","host":"s3://npm-registry-packages"}},"4.2.1":{"name":"abnf","version":"4.2.1","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@4.2.1","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"53fd0184517dc25c6a5e16ae3892dd7f437de619","tarball":"https://registry.npmjs.org/abnf/-/abnf-4.2.1.tgz","fileCount":13,"integrity":"sha512-wrtHVkiXjJUYXD4i/G660dA0XQ3YkD/pYQxBOWnxeQYk4Hkdqm3he1051RHij5UmO9smOQF8G5ocyAbdlPHV+Q==","signatures":[{"sig":"MEQCIA1x4/yV1+a+RNNYzZqddTDbYID8+/EUlbHOum5fJ1n7AiBzmc/c4pnGWWUFOhahFaoQ3QSOje69RJwQT8sPaLNuFw==","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@4.2.1","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":96291},"main":"lib/abnf.js","pnpm":{"overrides":{"cross-spawn":"^7.0.6","@eslint/plugin-kit":"^0.2.4"}},"type":"module","engines":{"node":">=18"},"gitHead":"32d92450f4a2b960607e635d8b4714f53435e2e4","_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.9.0","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.11.0","dependencies":{"peggy":"^4.2.0","commander":"^12.1.0"},"_hasShrinkwrap":false,"_npmOperationalInternal":{"tmp":"tmp/abnf_4.2.1_1733872295170_0.7450932162628228","host":"s3://npm-registry-packages-npm-production"}},"4.3.0":{"name":"abnf","version":"4.3.0","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"_id":"abnf@4.3.0","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"fd7347516ea09e18291f988b185c40efe10929c4","tarball":"https://registry.npmjs.org/abnf/-/abnf-4.3.0.tgz","fileCount":13,"integrity":"sha512-olYzmdIkOVdSLaB1AjEuuwuwvR1uP/XN3IFt6Yixj2+UYuvgxVPD7ktK1miRhtqhR4IQtp4vYTPxwimEZk+zOA==","signatures":[{"sig":"MEQCICGeuMjy6CLIDQcXs7jKamJ32dvi7n+Q6FSyVINLvl13AiAWm+IiDaoWW3OS5qLlWbXf4jhZj3I/lIodQO7wcwLN/g==","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@4.3.0","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":100447},"main":"lib/abnf.js","type":"module","engines":{"node":">=18"},"gitHead":"30ca1a01b5a53f6cdde1103fcdce6797539fa7ca","_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.9.0","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.12.0","dependencies":{"peggy":"^4.2.0","commander":"^13.0.0"},"_hasShrinkwrap":false,"_npmOperationalInternal":{"tmp":"tmp/abnf_4.3.0_1736024407570_0.13524445172642263","host":"s3://npm-registry-packages-npm-production"}},"4.3.1":{"name":"abnf","version":"4.3.1","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"license":"Apache-2.0","_id":"abnf@4.3.1","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"},{"name":"Steven R. Loomis","email":"srl295@codehivetx.us"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"558c9959b101c99cd1db9d4ff310a1557bd8ccda","tarball":"https://registry.npmjs.org/abnf/-/abnf-4.3.1.tgz","fileCount":13,"integrity":"sha512-j4A8wWqKqkcSjx5xFESo9GtW2EUvlUZutcWB1knhxSP9kaXJ/YwL0g6dvMhHRjCPCNsIWwNGoKMHzPwemSpCvw==","signatures":[{"sig":"MEYCIQCnU60IbqIT1AK9W0OFZeaQHBFFWyp+p/qX2Uflp8IBNQIhAKpdHaJ9gDEBOwWWJlFC3C1mSxglu0Hp0B9ylOM8zgRW","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@4.3.1","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":100932},"main":"lib/abnf.js","type":"module","engines":{"node":">=18"},"gitHead":"101b6688dd0a8e904695630656f9cb3047f74924","_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.9.0","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.12.0","dependencies":{"peggy":"^4.2.0","commander":"^13.0.0"},"_hasShrinkwrap":false,"_npmOperationalInternal":{"tmp":"tmp/abnf_4.3.1_1736443608139_0.5692003866739843","host":"s3://npm-registry-packages-npm-production"}},"5.0.0":{"name":"abnf","version":"5.0.0","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"license":"Apache-2.0","_id":"abnf@5.0.0","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"},{"name":"Steven R. Loomis","email":"srl295@codehivetx.us"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"09bf932ba67ac77d457678647eb9985e9e5dceae","tarball":"https://registry.npmjs.org/abnf/-/abnf-5.0.0.tgz","fileCount":13,"integrity":"sha512-IbfCNRDUPZtyRRJ7Vle+rZ7rh6OaMVb4qHE/dIR4s+STXjEw1rf++vodVcozyOGUUHelFAWpSbe0LODm1rrQwQ==","signatures":[{"sig":"MEYCIQCBJDXdVFRWwbnGW+AXmVDuhXKEQyZThatbyRmBGzZrewIhAKsZnb5Aj4wT3TVZ1bAYn/kDY+Uv/RTWgYJnYJYVhMWV","keyid":"SHA256:DhQ8wR5APBvFHLF/+Tc+AYvPOdTpcIDqOhxsBHRwC7U"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@5.0.0","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":100284},"main":"lib/abnf.js","type":"module","engines":{"node":">=20"},"gitHead":"cbde914ea873fe0429181a122e943c2391c596c6","_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.9.2","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.15.0","dependencies":{"peggy":"^5.0.0","commander":"^13.1.0"},"_hasShrinkwrap":false,"_npmOperationalInternal":{"tmp":"tmp/abnf_5.0.0_1746646912226_0.12032049818404045","host":"s3://npm-registry-packages-npm-production"}},"5.0.1":{"name":"abnf","version":"5.0.1","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"license":"Apache-2.0","_id":"abnf@5.0.1","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"},{"name":"Steven R. Loomis","email":"srl295@codehivetx.us"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"d647b6d3deb832faaa309efbdd3bb563dfa176fc","tarball":"https://registry.npmjs.org/abnf/-/abnf-5.0.1.tgz","fileCount":13,"integrity":"sha512-ljQK2eWmBvJhgYWble9GMKBLCqLSxgBHVh+yxkSa18RjtsOSf/lIjpUjosQ0ZsWYvCJjWqIJ92Q5Yted2BVbaw==","signatures":[{"sig":"MEUCIB5XScD8SKBOMomWHuKt9VBOAMj5v7UCuUYzcydaPTGsAiEA+wdOaBzlYz2KyqDOCn9nET5gpj8M1SX0M/kEchaqGJo=","keyid":"SHA256:DhQ8wR5APBvFHLF/+Tc+AYvPOdTpcIDqOhxsBHRwC7U"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@5.0.1","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":100284},"main":"lib/abnf.js","type":"module","engines":{"node":">=20"},"gitHead":"a5a1623c3d6fd540d7ed488fb808d26584e9098e","_npmUser":{"name":"hildjj","actor":{"name":"hildjj","type":"user","email":"joe-github@cursive.net"},"email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.9.2","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.16.0","dependencies":{"peggy":"^5.0.4","commander":"^14.0.0"},"_hasShrinkwrap":false,"_npmOperationalInternal":{"tmp":"tmp/abnf_5.0.1_1750462224232_0.5211515408766667","host":"s3://npm-registry-packages-npm-production"}},"5.0.2":{"name":"abnf","version":"5.0.2","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"license":"Apache-2.0","_id":"abnf@5.0.2","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"},{"name":"Steven R. Loomis","email":"srl295@codehivetx.us"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"a7ff5e5590dbbd330780dd634a0a9e648d817185","tarball":"https://registry.npmjs.org/abnf/-/abnf-5.0.2.tgz","fileCount":13,"integrity":"sha512-UznXBq3vrkQiIKO8HfpGjoLnwlGeDcJsz9QLD3q6/hBln1F6UpN1B2oNAndJ6GKAfoX2QJRQIGNHEtctYogOZQ==","signatures":[{"sig":"MEUCIQDQ5Uy551ilLNZTyrlG6KDSJKk3/XIoypKe/kKI41O9ZQIgNH05VoPAmTZ0CpSgHxanC/naovLO+pxCDb22DEJqn/o=","keyid":"SHA256:DhQ8wR5APBvFHLF/+Tc+AYvPOdTpcIDqOhxsBHRwC7U"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@5.0.2","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":100288},"main":"lib/abnf.js","type":"module","engines":{"node":">=20"},"gitHead":"41fbda16cfb097aea59376647638303e930cfd30","_npmUser":{"name":"hildjj","email":"joe-github@cursive.net"},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"10.9.2","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"22.17.1","dependencies":{"peggy":"^5.0.6","commander":"^14.0.0"},"_hasShrinkwrap":false,"_npmOperationalInternal":{"tmp":"tmp/abnf_5.0.2_1754422866663_0.43108507765438997","host":"s3://npm-registry-packages-npm-production"}},"5.0.3":{"name":"abnf","version":"5.0.3","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"license":"Apache-2.0","_id":"abnf@5.0.3","maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"},{"name":"Steven R. Loomis","email":"srl295@codehivetx.us"}],"homepage":"https://github.com/hildjj/node-abnf","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"bin":{"abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js","abnf_check":"bin/abnf_check.js"},"dist":{"shasum":"fd27ed0a069e26aa41aedef5297c6bf1568bf717","tarball":"https://registry.npmjs.org/abnf/-/abnf-5.0.3.tgz","fileCount":13,"integrity":"sha512-3r4jCX0qlUq0mcLG0lCBJcPMOuxem2e2NvPhspQQWd9HnLvfrX4bJfXw7IoK/J0sOh0UKM4+BAxyJb4X7J9WeA==","signatures":[{"sig":"MEUCIEBAMyl3uJpcn0PjipYPYv7upM8bdxSA44gSEraktylWAiEA9EOdaNO/qU2oMaW7r6ukpmB8CW6UOslmZgXChFDxXU0=","keyid":"SHA256:DhQ8wR5APBvFHLF/+Tc+AYvPOdTpcIDqOhxsBHRwC7U"}],"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@5.0.3","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"unpackedSize":100501},"main":"lib/abnf.js","pnpm":{"overrides":{"c8@11.0.0>yargs":"18.0.0","supertap@3.0.1>js-yaml":"3.14.2","concordance@5.0.4>lodash":"4.17.23","@mapbox/node-pre-gyp@2.0.0>tar":"7.5.9"}},"type":"module","engines":{"node":">=20"},"gitHead":"d47f932f16882b3480c6616d6754b6c2231c1b45","_npmUser":{"name":"GitHub Actions","email":"npm-oidc-no-reply@github.com","trustedPublisher":{"id":"github","oidcConfigId":"oidc:cc08bf98-914b-469d-84f7-b8a303efd5b0"}},"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"_npmVersion":"11.8.0","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","directories":{},"_nodeVersion":"24.13.1","dependencies":{"peggy":"^5.1.0","commander":"^14.0.3"},"_hasShrinkwrap":false,"_npmOperationalInternal":{"tmp":"tmp/abnf_5.0.3_1772400469843_0.4582699087685753","host":"s3://npm-registry-packages-npm-production"}},"5.0.4":{"name":"abnf","description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","version":"5.0.4","license":"Apache-2.0","author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"},{"name":"Steven R. Loomis","email":"srl295@codehivetx.us"}],"homepage":"https://github.com/hildjj/node-abnf","repository":{"url":"git://github.com/hildjj/node-abnf.git"},"keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"bin":{"abnf_check":"bin/abnf_check.js","abnf_ast":"bin/abnf_ast.js","abnf_gen":"bin/abnf_gen.js","abnf_test":"bin/abnf_test.js"},"main":"lib/abnf.js","type":"module","dependencies":{"commander":"^14.0.3","peggy":"^5.1.0"},"engines":{"node":">=20"},"gitHead":"efbc11dd8036d0d0bb7ff7ea98f01cf6eb790ab4","_id":"abnf@5.0.4","bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"_nodeVersion":"24.14.0","_npmVersion":"11.9.0","dist":{"integrity":"sha512-59zcbL9acak54gMAUeEoaexkBBfo6hD0UFP6oIxMY8hHcxnsulqb/WYYf/t++ayrboQB90zW2SXvGHaS5PM4mw==","shasum":"087aafc3fb371dd2f119c3f69bb148775a30897c","tarball":"https://registry.npmjs.org/abnf/-/abnf-5.0.4.tgz","fileCount":13,"unpackedSize":100289,"attestations":{"url":"https://registry.npmjs.org/-/npm/v1/attestations/abnf@5.0.4","provenance":{"predicateType":"https://slsa.dev/provenance/v1"}},"signatures":[{"keyid":"SHA256:DhQ8wR5APBvFHLF/+Tc+AYvPOdTpcIDqOhxsBHRwC7U","sig":"MEUCIQD6K0lMWr9GhlqtXA6f9+G3z3OLNDbFoE5Ec4y9kHr2XgIgGLkN8x1BTPKED5Atoph8jiyQ9kQBBqa1bfcWvvo7iCM="}]},"_npmUser":{"name":"GitHub Actions","email":"npm-oidc-no-reply@github.com","trustedPublisher":{"id":"github","oidcConfigId":"oidc:cc08bf98-914b-469d-84f7-b8a303efd5b0"}},"directories":{},"maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"_npmOperationalInternal":{"host":"s3://npm-registry-packages-npm-production","tmp":"tmp/abnf_5.0.4_1773163030878_0.5211291861280383"},"_hasShrinkwrap":false}},"time":{"created":"2012-05-29T08:18:11.052Z","modified":"2026-03-10T17:17:11.321Z","0.0.0":"2012-05-29T08:18:13.117Z","0.0.1":"2012-05-29T16:38:57.944Z","0.0.2":"2012-05-29T23:40:30.776Z","0.0.3":"2012-07-07T17:53:03.827Z","0.0.4":"2013-06-07T21:45:37.466Z","0.0.5":"2013-06-10T15:35:38.589Z","1.0.0":"2023-03-27T17:20:18.215Z","2.0.0":"2023-06-30T17:07:12.581Z","3.0.0":"2024-04-19T16:24:25.157Z","3.0.1":"2024-05-12T16:07:43.927Z","4.0.1":"2024-08-29T16:34:29.293Z","4.0.2":"2024-11-07T17:45:05.924Z","4.1.0":"2024-11-09T15:11:52.454Z","4.2.0":"2024-11-12T21:46:16.058Z","4.2.1":"2024-12-10T23:11:35.345Z","4.3.0":"2025-01-04T21:00:07.802Z","4.3.1":"2025-01-09T17:26:48.361Z","5.0.0":"2025-05-07T19:41:52.400Z","5.0.1":"2025-06-20T23:30:24.417Z","5.0.2":"2025-08-05T19:41:06.860Z","5.0.3":"2026-03-01T21:27:49.980Z","5.0.4":"2026-03-10T17:17:11.040Z"},"bugs":{"url":"https://github.com/hildjj/node-abnf/issues"},"author":{"name":"Joe Hildebrand","email":"joe-github@cursive.net"},"license":"Apache-2.0","homepage":"https://github.com/hildjj/node-abnf","keywords":["grammar","parser","generator","abnf","Backus–Naur","rfc","rfc5234","rfc7405"],"repository":{"url":"git://github.com/hildjj/node-abnf.git"},"description":"Augmented Backus-Naur Form (ABNF) parsing.  See RFC 5234.","contributors":[{"name":"Dominique Hazaël-Massieux","email":"dom@w3.org"},{"name":"ZP-ZPanda","email":"zp.zpanda@gmail.com"},{"name":"Steven R. Loomis","email":"srl295@codehivetx.us"}],"maintainers":[{"name":"hildjj","email":"joe-github@cursive.net"}],"readme":"# Parse ABNF grammars\n\nFor more information on the flavor of ABNF\n([Augmented Backus-Naur Form](https://en.wikipedia.org/wiki/Augmented_Backus%E2%80%93Naur_form)) supported by this project,\nsee [RFC 5234](http://tools.ietf.org/html/rfc5234)\nand [RFC 7405](https://www.rfc-editor.org/rfc/rfc7405).\n\n## Installation:\n\n    npm install -g abnf\n\n## Example:\n\n    import { parseFile } from \"abnf\";\n    const rules = await parseFile(\"myfile.abnf\");\n\n## CLI\n\nThere are a few binaries included:\n\n### abnf_check\n\nCheck the given ABNF file for correctness.\n\n```txt\nUsage: abnf_check [options] [abnfFile...]\n\nCheck ABNF files for syntax, unused rules, and undefined rules\n\nOptions:\n  -h, --help  display help for command\n```\n\n### abnf_ast\n\nOutput the generated abstract syntax tree for the ABNF input.  This output is\nmostly diagnostic in nature, not really meant to be parsed.\n\n```txt\nUsage: abnf_ast [options] [abnfFile...]\n\nOutput all of the rules derived from a given ABNF file\n\nOptions:\n  -l,--location  don't remove location information\n  -h, --help     display help for command\n```\n\n### abnf_gen\n\nGenerate a [Peggy](https://peggyjs.org/) or [Pest](https://pest.rs/) grammar\nfrom the ABNF.  The idea is that you could then annotate this grammar with\nactions in order to create a useful parser.\n\n```txt\nUsage: abnf_gen [options] [abnfFile...]\n\nCreate a grammar from an ABNF file\n\nArguments:\n  abnfFile                    ABNF files to turn into grammars.\n\nOptions:\n  -f, --format <format>       Output format (choices: \"peggy\", \"pest\", default:\n                              \"peggy\")\n  -s, --startRule <ruleName>  Start rule for generated grammar.  Defaults to\n                              first rule in ABNF grammar.  Can be specified\n                              multiple times.\n  --stubs                     Generate stubs for rules that do not exist, rather\n                              than failing.\n  -o, --output <file>         Output grammar file name.  Derived from input file\n                              name if not specified. (default: \"stdin.peggy\")\n  -u, --unused                Output rules that are not reachable from the start\n                              rule\n  -c, --core                  Include core rules from RFC 5234, Appendix B.\n  -h, --help                  display help for command\n```\n\n### abnf_test\n\nUsing an ABNF, test inputs to see if they match.  Returns the Peggy parse\ntree, which will likely be somewhat confusing until you're familiar with Peggy.\n\n```txt\nUsage: abnf_test [options] [abnfFile...]\n\nSend test inputs to an ABNF grammar\n\nArguments:\n  abnfFile                    The ABNF to test.\n\nOptions:\n  -o, --output                Output grammar source, if not testing.  Generated\n                              from peggyFile name if needed.\n  -s, --startRule <ruleName>  When testing, use this as the start rule.\n  -t, --test <string>         String to check against grammar.\n  -T, --testFile <file>       File contents to check against grammar.\n  --trace                     Turn on peggy tracing\n  -h, --help                  display help for command\n```\n\n## Suggested Workflow\n\n```sh\n$ cat << EOF > foo.abnf\nf = \"abc\"\nEOF\n$ abnf_gen foo.abnf\n$ cat foo.peggy\nf\n  = \"abc\"i\n$ abnf_test foo.abnf -t abc\n'abc'\n$ abnf_test foo.peggy -t ab\nError: Expected \"abc\" but \"a\" found.\n --> command line:1:1\n  |\n1 | ab\n  | ^\n```\n\n## API\n\n### .parseFile(input)\n\nParse the file with the given name, returning a promise for a Rules object.\n\n### .parseString(input, grammarSource = \"unknown\")\n\nParse the given string and return a Rules object.  The `grammarSource` is\nthe name of the file that the input came from.\n\n### .parseStream(stream, grammarSource = \"stdin\")\n\nRead the stream, parse it, and return a promise for a Rules object.  The\n`grammarSource` is the name of the file that the input came from.\n\n### .checkRefs(rules)\n\nThis is used by the `abnf_check` utility, and returns null if there are no reference errors, otherwise returns an array of error strings. Checks for unused or undefined rules.\n\n## Returned Rules object shape\n\n### Rules.first\n\nThe name of the first rule in the input grammar.\n\n### Rules.defs\n\nA hash of Rule objects indexed by uppercase rulename.\n\n### Rules.refs\n\nAn array of RuleRef objects.\n\n### Rule.name\n\nThe name of the rule\n\n### Rule.loc\n\nThe Peggy location in the input file where the rule name was defined\n\n### Rule.def\n\nThe definition of the rule.  More information forthcoming.\n\n### RuleRef.name\n\nThe name of the rule that was referenced\n\n### RuleRef.loc\n\nThe Peggy location in the input file where the rule name was referenced.\n\n---\n\n[![Tests](https://github.com/hildjj/node-abnf/actions/workflows/node.js.yml/badge.svg)](https://github.com/hildjj/node-abnf/actions/workflows/node.js.yml)\n[![codecov](https://codecov.io/gh/hildjj/node-abnf/branch/main/graph/badge.svg?token=waIK6vIrH6)](https://codecov.io/gh/hildjj/node-abnf)\n","readmeFilename":"README.md"}