{"bugs":{"url":"https://github.com/prettymuchbryce/node-http-status/issues"},"dist":{"shasum":"862a391b21e9dddad796d6cf38ff084c2dc678fd","tarball":"https://registry.npmjs.org/http-status-codes/-/http-status-codes-2.0.0-beta.3.tgz","fileCount":4,"integrity":"sha512-ezah+DHmkt6x2/ipHJokIu4LikdwdD98xpkC/IwJUNuuw/tpRxeXhEtvShUVCWzSTGA/MJON6pad4Pk1sajZIg==","signatures":[{"sig":"MEYCIQCDv+pMwjEeYxEQTljGkIIMwksrmOeeyLxtyTznfklTcgIhAIxuLvviOh1jqsleLfuc15b2MdsFqQgNaw6VXkFdkJAV","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"unpackedSize":56495,"npm-signature":"-----BEGIN PGP SIGNATURE-----\r\nVersion: OpenPGP.js v3.0.4\r\nComment: https://openpgpjs.org\r\n\r\nwsFcBAEBCAAQBQJfQYrDCRA9TVsSAnZWagAAAVQP/1I4p84Dr66PX6ndT6uN\ncQT3YGOlNoiQMAi3+Ru4sxfxBd9tQzoI1nS0KsFquyq9ldt9srRAzp2WC6od\nOVELdGWu3VkGP/MlUZuM51ppomIoGgDN4lZ84uGb4c4sMVb2W8ok7txcMmI7\nel7zvQ1HXBRz/qLfUEntrb6Im2BHwAl66iVBl9WUFom7V/TIF0BmQ7cZxgSz\nyLOzXyxHFEXov0WLQ8mU3O30lpTNBJ4xJxptXvLttVLMBc0pitPSSu2nxFIu\nXJQGj/RsR1yPY4nyJJ86iSQuv9Gvbh8gHksB2f7zylnio/D/iVCxfp6uifWi\naY4jaPBDjumIUwESOJpzdzkGf7hNPEj455fnSQtvo43WJyj7MRT/FzkwYnGU\ntsfjbOKOl79CJBieddR1RifOdea++yRs+vaJr93rLbDV0J3aEOvJH/BF/QHn\nAomtlc4+XpF2Mnwkz/MvtKb6sMt6k95lMZVNGZxxsnHvRyznWfd9xbfTO8ys\n4ZkRWd9U6RpbdXOWcxwfGpipGMEHlYXmIFLkDe0Y8ijgzPBixLXDPuKU0Mwd\n908oxp6rIoLtaxzQv0JLEhriJdUzCYIMCS7TCWWF2x6Z+bcH0CxYYMbd9CSJ\n/dgXlgKHZk8mJ1n4Vqwjbw6GtByXwyLJGcdFElLyMa3ULtyrgZZ5PJC4IqhH\nw5zD\r\n=XIoE\r\n-----END PGP SIGNATURE-----\r\n"},"main":"./build/index.js","name":"http-status-codes","author":{"name":"Bryce Neal"},"readme":"# http-status-codes\n\nConstants enumerating the HTTP status codes. Based on the [Java Apache HttpStatus API](http://hc.apache.org/httpclient-3.x/apidocs/org/apache/commons/httpclient/HttpStatus.html).\n\nAll status codes defined in RFC1945 (HTTP/1.0), RFC2616 (HTTP/1.1), RFC2518 (WebDAV), RFC6585 (Additional HTTP Status Codes), and RFC7538 (Permanent Redirect) are supported.\n\nTypeScript or JavaScript. Completely library agnostic. No dependencies.\n\n## Installation\n\n```console\nnpm install http-status-codes --save\n```\n\n## Usage (express 4.x)\n\n```javascript\nimport { StatusCodes, ReasonPhrases, getReasonPhrase, getStatusCode } from 'http-status-codes';\n\nresponse\n\t.status(StatusCodes.OK)\n\t.send(ReasonPhrases.OK);\n\nresponse\n\t.status(StatusCodes.INTERNAL_SERVER_ERROR)\n\t.send({\n\t\terror: getReasonPhrase(StatusCodes.INTERNAL_SERVER_ERROR)\n\t});\n\nresponse\n\t.status(getStatusCode('Internal Server Error'))\n\t.send({\n\t\terror: 'Internal Server Error'\n\t});\n```\n\n## Codes \n\n| Code | Constant                        | Reason Phrase                   |\n| ---- | ------------------------------- | ------------------------------- |\n| 100  | CONTINUE                        | Continue                        |\n| 101  | SWITCHING_PROTOCOLS             | Switching Protocols             |\n| 102  | PROCESSING                      | Processing                      |\n| 200  | OK                              | OK                              |\n| 201  | CREATED                         | Created                         |\n| 202  | ACCEPTED                        | Accepted                        |\n| 203  | NON_AUTHORITATIVE_INFORMATION   | Non Authoritative Information   |\n| 204  | NO_CONTENT                      | No Content                      |\n| 205  | RESET_CONTENT                   | Reset Content                   |\n| 206  | PARTIAL_CONTENT                 | Partial Content                 |\n| 207  | MULTI_STATUS                    | Multi-Status                    |\n| 300  | MULTIPLE_CHOICES                | Multiple Choices                |\n| 301  | MOVED_PERMANENTLY               | Moved Permanently               |\n| 302  | MOVED_TEMPORARILY               | Moved Temporarily               |\n| 303  | SEE_OTHER                       | See Other                       |\n| 304  | NOT_MODIFIED                    | Not Modified                    |\n| 305  | USE_PROXY                       | Use Proxy                       |\n| 307  | TEMPORARY_REDIRECT              | Temporary Redirect              |\n| 308  | PERMANENT_REDIRECT              | Permanent Redirect              |\n| 400  | BAD_REQUEST                     | Bad Request                     |\n| 401  | UNAUTHORIZED                    | Unauthorized                    |\n| 402  | PAYMENT_REQUIRED                | Payment Required                |\n| 403  | FORBIDDEN                       | Forbidden                       |\n| 404  | NOT_FOUND                       | Not Found                       |\n| 405  | METHOD_NOT_ALLOWED              | Method Not Allowed              |\n| 406  | NOT_ACCEPTABLE                  | Not Acceptable                  |\n| 407  | PROXY_AUTHENTICATION_REQUIRED   | Proxy Authentication Required   |\n| 408  | REQUEST_TIMEOUT                 | Request Timeout                 |\n| 409  | CONFLICT                        | Conflict                        |\n| 410  | GONE                            | Gone                            |\n| 411  | LENGTH_REQUIRED                 | Length Required                 |\n| 412  | PRECONDITION_FAILED             | Precondition Failed             |\n| 413  | REQUEST_TOO_LONG                | Request Entity Too Large        |\n| 414  | REQUEST_URI_TOO_LONG            | Request-URI Too Long            |\n| 415  | UNSUPPORTED_MEDIA_TYPE          | Unsupported Media Type          |\n| 416  | REQUESTED_RANGE_NOT_SATISFIABLE | Requested Range Not Satisfiable |\n| 417  | EXPECTATION_FAILED              | Expectation Failed              |\n| 418  | IM_A_TEAPOT                     | I'm a teapot                    |\n| 419  | INSUFFICIENT_SPACE_ON_RESOURCE  | Insufficient Space on Resource  |\n| 420  | METHOD_FAILURE                  | Method Failure                  |\n| 422  | UNPROCESSABLE_ENTITY            | Unprocessable Entity            |\n| 423  | LOCKED                          | Locked                          |\n| 424  | FAILED_DEPENDENCY               | Failed Dependency               |\n| 428  | PRECONDITION_REQUIRED           | Precondition Required           |\n| 429  | TOO_MANY_REQUESTS               | Too Many Requests               |\n| 431  | REQUEST_HEADER_FIELDS_TOO_LARGE | Request Header Fields Too Large |\n| 500  | INTERNAL_SERVER_ERROR           | Server Error                    |\n| 501  | NOT_IMPLEMENTED                 | Not Implemented                 |\n| 502  | BAD_GATEWAY                     | Bad Gateway                     |\n| 503  | SERVICE_UNAVAILABLE             | Service Unavailable             |\n| 504  | GATEWAY_TIMEOUT                 | Gateway Timeout                 |\n| 505  | HTTP_VERSION_NOT_SUPPORTED      | HTTP Version Not Supported      |\n| 507  | INSUFFICIENT_STORAGE            | Insufficient Storage            |\n| 511  | NETWORK_AUTHENTICATION_REQUIRED | Network Authentication Required |\n\n## Migrating from v1.x.x\n\nv2 is backwards compatible with v1, but if you are migrating from http-status-codes v1 to v2, there are a couple of changes that are recommended.\n\n### getStatusText renamed getReasonPhrase\n\nTo fix this, simply rename `getStatusText()` to `getReasonPhrase()`. The function is otherwise the same as it was before.\n\n**bad** ❌\n\n```\ngetStatusText(200);\n```\n\n**good** ✅\n\n```\ngetReasonPhrase(200);\n```\n\n### No wildcard imports\nWe're moving away from wildcard imports in favor of selective imports.\n\n**bad** ❌\n\n```typescript\nimport * as HttpStatus from 'http-status-codes';\n```\n\n**good** ✅\n\n```typescript\nimport { StatusCodes } from 'http-status-codes';\n\n```\nThese changes are __optional__ now, but may be required in a future major version so please consider making them now.\n\n\n## Proposing a new status code\n\nIf you'd like to propose a new status code, feel free to update \"codes.json\" with the necessary\ninformation and open a pull request. No need to modify source code or even this README.\nThe update-codes script will handle this all for you.\n\nIn general, we try to include only codes that have an official RFC and have been approved, however\nexceptions will be made if the code is already in widespread use in the wild.\n\n## Steps to build and publish\n\n```shell\nnpm run update-codes\nnpm run test\nnpm run build\nnpm version [major | minor | patch]\nnpm run publish\n```\n","gitHead":"1d3ac307e9366547b0fdb615415e8801f9cbd176","license":"MIT","scripts":{"lint":"eslint .","test":"jest ./src","build":"npm run build-ts && npm run build-concat && npm run build-cleanup","build-ts":"tsc --project tsconfig-build.json","build-concat":"ncc build ./build-tmp/index.js -o ./build","update-codes":"ts-node --project ./scripts/tsconfig.json ./scripts/update-codes","build-cleanup":"rm -rf ./build-tmp"},"_npmUser":{"name":"prettymuchbryce","email":"brycedneal@gmail.com"},"homepage":"https://github.com/prettymuchbryce/node-http-status#readme","keywords":["node","http","apache","HttpStatus","httpclient","status","codes"],"repository":{"url":"git+https://github.com/prettymuchbryce/node-http-status.git","type":"git"},"_npmVersion":"6.14.4","description":"Constants enumerating the HTTP status codes. Based on the Java Apache HttpStatus API.","directories":{},"maintainers":[{"name":"prettymuchbryce","email":"brycedneal@gmail.com"}],"_nodeVersion":"13.14.0","_hasShrinkwrap":false,"readmeFilename":"README.md","devDependencies":{"jest":"^26.4.0","eslint":"^7.7.0","ts-jest":"^26.2.0","fs-extra":"^9.0.1","ts-morph":"^7.3.0","typescript":"^3.9.7","@types/jest":"^26.0.10","@vercel/ncc":"^0.23.0","markdown-table":"^2.0.0","@types/fs-extra":"^9.0.1","eslint-plugin-import":"^2.22.0","@types/markdown-table":"^2.0.0","@typescript-eslint/parser":"^3.9.1","eslint-config-airbnb-typescript":"^9.0.0","@typescript-eslint/eslint-plugin":"^3.9.0"},"_npmOperationalInternal":{"tmp":"tmp/http-status-codes_2.0.0-beta.3_1598130882952_0.3458377885313697","host":"s3://npm-registry-packages"},"_id":"http-status-codes@2.0.0-beta.3","version":"2.0.0-beta.3"}