{"_id":"rfc6920-toolbox","_rev":"12-c58eac83c7cb93fde6cec6f972bed3c0","name":"rfc6920-toolbox","description":"Encode/decode RFC6920 \"named information\" URIs","dist-tags":{"latest":"0.1.1"},"versions":{"0.0.0":{"name":"rfc6920-toolbox","version":"0.0.0","description":"RFC6920 \"named information\" tools","author":{"name":"Neftaly Hernandez","email":"neftaly.hernandez@gmail.com"},"license":"MIT","repository":{"type":"git","url":"git://github.com/neftaly/npm-rfc6920-toolbox.git"},"main":"rfc6920-toolbox","scripts":{"test":"expresso"},"keywords":["RFC6920","named information","ni URI","URI"],"dependencies":{"base64formatter":"0.x.x","crypto":"~0.0.3","node-qs-serialization":"~0.0.2"},"devDependencies":{"expresso":"0.9.2"},"engines":{"node":">= 0.10.4"},"gitHead":"8e675c0bde90454d7d925274277e9deca5c70c2d","bugs":{"url":"https://github.com/neftaly/npm-rfc6920-toolbox/issues"},"homepage":"https://github.com/neftaly/npm-rfc6920-toolbox","_id":"rfc6920-toolbox@0.0.0","_shasum":"d38c9f07d0b1f47e93d98cce19a7c0f7b3389d2f","_from":".","_npmVersion":"1.4.28","_npmUser":{"name":"neftaly","email":"neftaly.hernandez@gmail.com"},"maintainers":[{"name":"neftaly","email":"neftaly.hernandez@gmail.com"}],"dist":{"shasum":"d38c9f07d0b1f47e93d98cce19a7c0f7b3389d2f","tarball":"https://registry.npmjs.org/rfc6920-toolbox/-/rfc6920-toolbox-0.0.0.tgz","integrity":"sha512-2D13/d7wlfGswk+Y5Fu1v3mcBEI6pJOT4VqNrVh6RVVPiAzRg65XHMyknCmb3WBja6XRu5RK6yBIkg9fvqqEZQ==","signatures":[{"keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA","sig":"MEUCIQCFzuKAzDny/z8JmxSLHt8Nr10ogau1eAlu6159gqDZBAIgUf9x2hVGG0PIWZ1lgx9Hkc6Uk8L0ChSnJnuLMp5VEtY="}]}},"0.1.0":{"name":"rfc6920-toolbox","version":"0.1.0","description":"Encode/decode RFC6920 \"named information\" URIs","author":{"name":"Neftaly Hernandez","email":"neftaly.hernandez@gmail.com"},"license":"MIT","repository":{"type":"git","url":"https://github.com/neftaly/npm-rfc6920-toolbox.git"},"main":"main","scripts":{"test":"mocha"},"keywords":["rfc6920-toolbox","RFC6920","named information","ni URI","URI"],"dependencies":{"ramda":"~0.8.0","base64-format":"~0.1.0","crypto":"~0.0.3","node-qs-serialization":"~0.0.2"},"devDependencies":{"mocha":"~2.1.0"},"engines":{"node":">= 0.10.4"},"gitHead":"d0884e76805e2a6bab3e617dc7cd06130cc57104","bugs":{"url":"https://github.com/neftaly/npm-rfc6920-toolbox/issues"},"homepage":"https://github.com/neftaly/npm-rfc6920-toolbox","_id":"rfc6920-toolbox@0.1.0","_shasum":"c58f568720d8d9cac4c90fc804be5a88dd40bb6e","_from":".","_npmVersion":"1.4.28","_npmUser":{"name":"neftaly","email":"neftaly.hernandez@gmail.com"},"maintainers":[{"name":"neftaly","email":"neftaly.hernandez@gmail.com"}],"dist":{"shasum":"c58f568720d8d9cac4c90fc804be5a88dd40bb6e","tarball":"https://registry.npmjs.org/rfc6920-toolbox/-/rfc6920-toolbox-0.1.0.tgz","integrity":"sha512-CmJUwrQLf29FY2aQ6lSgSV4R3bAKkg4e9qBAmHSBufJiX1wDhg0VWi0HlatB6HlON8pOVgGvA59erPN/eSU6Ww==","signatures":[{"keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA","sig":"MEQCIEZQzDoyJXEOI3FkrEf3FATVtkrB5Aeenlq2fmCqL6T+AiAkx1lrIBO9k/rlM/F7chcOAiqaDnhtSYAcaenkf8WgiA=="}]}},"0.1.1":{"name":"rfc6920-toolbox","version":"0.1.1","description":"Encode/decode RFC6920 \"named information\" URIs","author":{"name":"Neftaly Hernandez","email":"neftaly.hernandez@gmail.com"},"license":"MIT","repository":{"type":"git","url":"https://github.com/neftaly/npm-rfc6920-toolbox.git"},"main":"main","scripts":{"test":"mocha"},"keywords":["rfc6920-toolbox","RFC6920","named information","ni","ni URI","URI"],"dependencies":{"base64-format":"~0.1.2","better-require":"~0.0.3","buffer":"~3.0.1","crypto-browserify":"~3.9.11","ramda":"~0.8.0","url":"~0.10.2"},"browser":{"crypto":"crypto-browserify","url":"url","buffer":"buffer"},"devDependencies":{"mocha":"~2.1.0"},"engines":{"node":">= 0.10.4"},"gitHead":"2971ee446e6ae90bdf4f26fc728d248928ea5f0b","bugs":{"url":"https://github.com/neftaly/npm-rfc6920-toolbox/issues"},"homepage":"https://github.com/neftaly/npm-rfc6920-toolbox","_id":"rfc6920-toolbox@0.1.1","_shasum":"c6db11b3e48ebed73f7ea03fb08cc5e5ee17add6","_from":".","_npmVersion":"1.4.28","_npmUser":{"name":"neftaly","email":"neftaly.hernandez@gmail.com"},"maintainers":[{"name":"neftaly","email":"neftaly.hernandez@gmail.com"}],"dist":{"shasum":"c6db11b3e48ebed73f7ea03fb08cc5e5ee17add6","tarball":"https://registry.npmjs.org/rfc6920-toolbox/-/rfc6920-toolbox-0.1.1.tgz","integrity":"sha512-qwEgNqJNYuMT15PJ3auuXrD6Btqbjs3DOe+txv3vn87gDQWGgxBu9XY+A7zC7iOpm97hAXRtEjmThQ3QYpk9zw==","signatures":[{"keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA","sig":"MEQCIBgfVq1Bkxh+FWe1Ok6CoRhQKpwKhLv1FAXUG4FcZG43AiB0/L7jGQpNnl4q0wRJTQAyUKAQVuhRSijCaygueribfg=="}]}}},"readme":"# rfc6920-toolbox [![Build Status](https://travis-ci.org/neftaly/npm-rfc6920-toolbox.svg?branch=master)](https://travis-ci.org/neftaly/npm-rfc6920-toolbox)\n\nEncode/decode [RFC6920](https://tools.ietf.org/html/rfc6920) \"named information\" URI's.\n\nInstall\n-------\n```shell\nnpm install rfc6920-toolbox\n```\n\nAPI\n---\n* **digest(algorithm, data)** *= rfc6920DigestString*  \n    Create a base64uri encoded digest of `data`, using `algorithm`\n\n* **serialize(niData)** *= niUriString*  \n    Create a ni-URI string from a `niData` object\n\n* **deserialize(uri)** *= niDataObject*  \n    Create a `niData` object from a ni-URI string\n\nUsage\n-----\n```javascript\nvar rfc6920 = require(\"rfc6920-toolbox\");\n\nvar sourceCode = get_file_contents(\"https://code.jquery.com/jquery-1.10.2.min.js\");\n\nvar digest = rfc6920.digest(\"sha-256\", sourceCode); \n//=> \"C6CB9UYIS9UJeqinPHWTHVqh_E1uhG5Twh-Y5qFQmYg\"\n\nvar niData = {\n    algorithm: \"sha-256\",\n    digest: digest,\n\tparameters: {\n\t\t\"ct\": \"text/javascript\"\n\t}\n}\n\nvar niUri = rfc6920.encode(niData); \n//=> \"ni:///sha-256;C6CB9UYIS9UJeqinPHWTHVqh_E1uhG5Twh-Y5qFQmYg?ct=text/javascript\"\n\nrfc6920.deserialize(niUri); \n//=> niData\n```\n\n**Note:** this module supports [currying](http://fr.umio.us/favoring-curry/).\n```javascript\nvar sha256Digest = rfc6920.digest(\"sha-256\");\n\nsha256Digest(sourceCode); \n//=> \"C6CB9UYIS9UJeqinPHWTHVqh_E1uhG5Twh-Y5qFQmYg\"\n```\n\n\"ni\" data\n---------\n```javascript\ndefaults = {\n\talgorithm: \"sha-256\",\n    authority: \"\",\n\tdigest: undefined, // Required\n\tparameters: {}\n}\n```\n\nKey: type **name** *= default*  \n\n* string **algorithm** *= \"sha-256\"*\n\t[RFC6920](https://tools.ietf.org/html/rfc6920#section-3) Digest Algorithm  \n    > Digest Algorithm:  The name of the digest algorithm, as specified in\n    >  the IANA registry defined in [Section 9.4](https://tools.ietf.org/html/rfc6920#section-9.4).\n\n* string **authority** *= \"\"*  \n    [RFC6920](https://tools.ietf.org/html/rfc6920#section-3) Authority value  \n    > Authority:  The optional authority component may assist applications\n    >  in accessing the object named by an ni-URI.  There is no default\n    >  value for the authority field.  (See Section 3.2.2 of [RFC3986]\n    >  for details.)  While ni names with and without an authority differ\n    >  syntactically from ni names with different authorities, all three\n    >  refer to the same object if and only if the digest algorithm,\n    >  length, and value are the same.\n\n* string **digest** *= undefined*  \n\t[RFC6920](https://tools.ietf.org/html/rfc6920#section-3) Digest Value  \n    > Digest Value:  The digest value MUST be encoded using the base64url\n    >  [RFC4648] encoding, with no \"=\" padding characters.\n\n* object **parameters** *= {}*  \n    Deserialized [RFC6920](https://tools.ietf.org/html/rfc6920#section-3) Query Parameters, in `key: value` format.  \n","maintainers":[{"name":"neftaly","email":"neftaly.hernandez@gmail.com"}],"time":{"modified":"2022-06-26T13:05:35.161Z","created":"2015-01-14T08:24:57.131Z","0.0.0":"2015-01-14T08:24:57.131Z","0.0.1":"2015-01-18T10:19:09.804Z","0.1.0":"2015-01-18T10:22:11.009Z","0.1.1":"2015-01-30T02:02:00.655Z"},"homepage":"https://github.com/neftaly/npm-rfc6920-toolbox","keywords":["rfc6920-toolbox","RFC6920","named information","ni","ni URI","URI"],"repository":{"type":"git","url":"https://github.com/neftaly/npm-rfc6920-toolbox.git"},"author":{"name":"Neftaly Hernandez","email":"neftaly.hernandez@gmail.com"},"bugs":{"url":"https://github.com/neftaly/npm-rfc6920-toolbox/issues"},"license":"MIT","readmeFilename":"README.md"}