{"bugs":{"url":"https://github.com/garycourt/uri-js/issues"},"dist":{"shasum":"cde6cccb3da47df9e4a0118f17d2a1fef4a1f69c","tarball":"https://registry.npmjs.org/uri-js/-/uri-js-3.0.1.tgz","integrity":"sha512-gstDj+dNkBLhfSgYms7JbQ17O/WW1rol4UK/tibpRd1v9uyvyuSQLptDU7niq3lyo+swE+hyYD2DbK6WjKIThw==","signatures":[{"sig":"MEUCIQC8/zEyXdEcZThe2d79cRwTC+HkrcTQ2Fwozc22VfhvjQIgEifiD+aqmv1l1FqFHZseHx98yLvYguSr4wmWZELVylI=","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}]},"main":"dist/es5/uri.all.js","name":"uri-js","_from":".","types":"dist/es5/uri.all.d.ts","author":{"name":"Gary Court","email":"gary.court@gmail.com"},"module":"dist/esnext/index.js","_shasum":"cde6cccb3da47df9e4a0118f17d2a1fef4a1f69c","gitHead":"802bcbf3c7c37b5671ffe67a7aca3fd65fd48bec","license":"BSD-2-Clause","scripts":{"test":"mocha -u mocha-qunit-ui dist/es5/uri.all.js tests/tests.js","build":"npm run build:esnext && npm run build:es5 && npm run build:es5:min","build:es5":"rollup -c && cp dist/esnext/uri.d.ts dist/es5/uri.all.d.ts && npm run build:es5:fix-sourcemap","build:esnext":"tsc","build:es5:min":"uglifyjs dist/es5/uri.all.js --support-ie8 --output dist/es5/uri.all.min.js --in-source-map dist/es5/uri.all.js.map --source-map uri.all.min.js.map --comments --compress --mangle --pure-funcs merge subexp  && mv uri.all.min.js.map dist/es5/ && cp dist/es5/uri.all.d.ts dist/es5/uri.all.min.d.ts","build:es5:fix-sourcemap":"sorcery -i dist/es5/uri.all.js"},"_npmUser":{"name":"garycourt","email":"gary.court@gmail.com"},"homepage":"https://github.com/garycourt/uri-js","keywords":["URI","IRI","IDN","URN","HTTP","HTTPS","MAILTO","RFC3986","RFC3987","RFC5891","RFC2616","RFC2818","RFC2141","RFC4122","RFC4291","RFC6068"],"repository":{"url":"git+ssh://git@github.com/garycourt/uri-js.git","type":"git"},"_npmVersion":"3.10.10","description":"An RFC 3986/3987 compliant, scheme extendable URI/IRI parsing/validating/resolving library for JavaScript.","directories":{"test":"tests"},"maintainers":[{"name":"garycourt","email":"gary.court@gmail.com"}],"_nodeVersion":"6.10.0","dependencies":{"punycode":"^2.1.0"},"devDependencies":{"mocha":"^3.2.0","rollup":"^0.41.6","sorcery":"^0.10.0","babel-cli":"^6.24.0","uglify-js":"^2.8.14","typescript":"^2.2.1","mocha-qunit-ui":"^0.1.3","babel-preset-latest":"^6.24.0","rollup-plugin-babel":"^2.7.1","rollup-plugin-node-resolve":"^2.0.0","babel-plugin-external-helpers":"^6.22.0"},"_npmOperationalInternal":{"tmp":"tmp/uri-js-3.0.1.tgz_1490641808290_0.7421848720405251","host":"packages-12-west.internal.npmjs.com"},"_id":"uri-js@3.0.1","version":"3.0.1"}