{"bugs":{"url":"https://github.com/garycourt/uri-js/issues"},"dist":{"shasum":"e16cb9ef7b4036d74be59dc7342258e6f1aca20e","tarball":"https://registry.npmjs.org/uri-js/-/uri-js-4.3.0.tgz","fileCount":40,"integrity":"sha512-Q9Q9RlMM08eWfdPPmDDrXd8Ny3R1sY/DaRDR2zTPPneJ6GYiLx3++fPiZobv49ovkYAnHl/P72Ie3HWXIRVVYA==","signatures":[{"sig":"MEQCIC5q2Be7KKh7EbeBNH5iJYy1P0ST8jt7AqVYzCRhqlImAiB4iipCphf85P20x5O5WHCrhuiLbzN4b1r2ztDZr1eDkw==","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"unpackedSize":421345,"npm-signature":"-----BEGIN PGP SIGNATURE-----\r\nVersion: OpenPGP.js v3.0.4\r\nComment: https://openpgpjs.org\r\n\r\nwsFcBAEBCAAQBQJfSv7ZCRA9TVsSAnZWagAARhMP/1k3ermDhttCNsbXd4lK\nxb986+aFwxnjD7siHnQJYGLDyj6iQLuo9oZ0DTTsIt6nHC8evgDOsBsaiamV\nFv41MtC2e97KLTIAbI9kAcsvvf4npNrAwr54ZJ6H/kfyLvRibhfTTmVNDJ4r\nDuosU++iOoO2IGzTWeM4/llbUP3HSMxI+fJsMKawnKhNPFS08OR7eEzr9gGI\nuSfFetHjCziWo2VubTWi1zI2H43sS61zLseaIGHhX403OKndC/LeWXVMzu6l\nCa798t/osiqufMiJcOf0AjxJLul2LGS8j5KQtVvzg7UF5O8e5F6NEv6KuvQY\nz4jj4TD/w+L65bXwM+27b0mrILNIukCXW4g5bQsfSNuOb819e5dXCzfo/YS/\nbX7GsYcegaDnny3rDPAUQU44RV7Cxe3l2n7IMLFwEULuQeUcCVgIOMPSpjQW\njkJESCdD36ORF2k48dKMJwyjcwArW2POBsTJDO8sW0H2/GvZoDt6UhBIEGlK\nUpUMGBXhfgLnqAFyAXk+/lswTizgJGSZTt+q9xLa3M/kMjOgaZCjXeEbhfYn\n8yjzwU5DDLDkRRLIPI1k0RgDLSOi+EV6JOnAXUdCa5TZr4wA/EBfRqw3k+7e\n1ar4ATyJ7COOOvG1fJQVcAidG7FYiZGcVbHJcgUd4B26Q99qiZNoSHfNpt+L\n976P\r\n=oosy\r\n-----END PGP SIGNATURE-----\r\n"},"main":"dist/es5/uri.all.js","name":"uri-js","types":"dist/es5/uri.all.d.ts","author":{"name":"Gary Court","email":"gary.court@gmail.com"},"gitHead":"424180cb7689c16d2f977988b4a181bf54bb187c","license":"BSD-2-Clause","scripts":{"test":"mocha -u mocha-qunit-ui dist/es5/uri.all.js tests/tests.js","build":"npm run build:esnext && npm run build:es5 && npm run build:es5:min","build:es5":"rollup -c && cp dist/esnext/uri.d.ts dist/es5/uri.all.d.ts && npm run build:es5:fix-sourcemap","build:esnext":"tsc","build:es5:min":"uglifyjs dist/es5/uri.all.js --support-ie8 --output dist/es5/uri.all.min.js --in-source-map dist/es5/uri.all.js.map --source-map uri.all.min.js.map --comments --compress --mangle --pure-funcs merge subexp && mv uri.all.min.js.map dist/es5/ && cp dist/es5/uri.all.d.ts dist/es5/uri.all.min.d.ts","build:es5:fix-sourcemap":"sorcery -i dist/es5/uri.all.js"},"_npmUser":{"name":"garycourt","email":"gary.court@gmail.com"},"homepage":"https://github.com/garycourt/uri-js","keywords":["URI","IRI","IDN","URN","UUID","HTTP","HTTPS","MAILTO","RFC3986","RFC3987","RFC5891","RFC2616","RFC2818","RFC2141","RFC4122","RFC4291","RFC5952","RFC6068","RFC6874"],"repository":{"url":"git+ssh://git@github.com/garycourt/uri-js.git","type":"git"},"_npmVersion":"6.14.6","description":"An RFC 3986/3987 compliant, scheme extendable URI/IRI parsing/validating/resolving library for JavaScript.","directories":{"test":"tests"},"maintainers":[{"name":"garycourt","email":"gary.court@gmail.com"}],"_nodeVersion":"12.18.3","dependencies":{"punycode":"^2.1.0"},"_hasShrinkwrap":false,"devDependencies":{"mocha":"^3.2.0","rollup":"^0.41.6","sorcery":"^0.10.0","babel-cli":"^6.26.0","uglify-js":"^2.8.14","typescript":"^2.8.1","mocha-qunit-ui":"^0.1.3","babel-preset-latest":"^6.24.1","rollup-plugin-babel":"^2.7.1","rollup-plugin-node-resolve":"^2.0.0","babel-plugin-external-helpers":"^6.22.0"},"_npmOperationalInternal":{"tmp":"tmp/uri-js_4.3.0_1598750425174_0.25728795153933026","host":"s3://npm-registry-packages"},"_id":"uri-js@4.3.0","version":"4.3.0"}