{"bugs":{"url":"https://github.com/garycourt/uri-js/issues"},"dist":{"shasum":"aa714261de793e8a82347a7bcc9ce74e86f28602","tarball":"https://registry.npmjs.org/uri-js/-/uri-js-4.4.0.tgz","fileCount":46,"integrity":"sha512-B0yRTzYdUCCn9n+F4+Gh4yIDtMQcaJsmYBDsTSG8g/OejKBodLQ2IHfN3bM7jUsRXndopT7OIXWdYqc1fjmV6g==","signatures":[{"sig":"MEYCIQDUPBtWJ2wUxInOUONbxRA6+rtZq36GuYFxfTCUPvrd+AIhAPeHkvA5RZLJ17Joa24sxcHEUXM3vmn0gn9Wv55IhBgd","keyid":"SHA256:jl3bwswu80PjjokCgh0o2w5c2U4LhQAE57gj9cz1kzA"}],"unpackedSize":435804,"npm-signature":"-----BEGIN PGP SIGNATURE-----\r\nVersion: OpenPGP.js v3.0.4\r\nComment: https://openpgpjs.org\r\n\r\nwsFcBAEBCAAQBQJfS/hFCRA9TVsSAnZWagAANNsP/3GypTnT3GjWWn+gLvQU\nGekN0Eo+0cz0VPVVyCI72fFUgSN7txFow7/4hRNjkmu8A1hIA9hw2FehonOy\nkf5eKMyGWxAKc6/UcfWtAgdUYRt66rVq2qqJHoHZyocCOGXw32aQTwBtz0H1\nBKzGZpPeXWjz1Y42PFqhWXBNxOG9Zyq0RH24pG3aOoNxky2tLrygAwG1keT1\nXxN4dzPjJEhN9uN9Wig/VCy7fM9L8MFrKducFNpjYem8IGIDfs0uhllGiiYI\nM6H1VTztAJRDAKPzg41Zt/iCMiGMKIQfARP5rvhMFQen+HjFETIXdomQzB5f\ndAhHIoMJbpX9kM0V0fuKVx0lVxtiIuqzqxVaHZJ1qFNTPSQSEPZPX/KyBr2E\nwiQKG7Bn2JMZby3c0Kb2t1ocNuXt1FEC4y+pkl1KRhLQ4S0a9gdpSfS+1lST\nUFqypQ27JRepjb+N4TqUFy1kjorTm7sFkzk4FF7RKL6raFeulcYLGB832XDk\n7Wt2sQR3MyvzvqYzyk2P52MEn4OGVLR5WowCjfqU6bpvOe8uwMsfHuWcA4iJ\n0yBJMZr7lr0bcvMNN7jSiUt1L7wSBKqLjvZ9h17FUqewshlWTKPzZIQE4+KL\nlQff98Jd8A28bmrCW8IpHVfBkxpsVxuyqLxVjHMbNID8LlnByNndfEMZKQSX\nYY4+\r\n=qU9S\r\n-----END PGP SIGNATURE-----\r\n"},"main":"dist/es5/uri.all.js","name":"uri-js","types":"dist/es5/uri.all.d.ts","author":{"name":"Gary Court","email":"gary.court@gmail.com"},"gitHead":"7cb6f9ccfa441f88de122e782fd34a27e3076057","license":"BSD-2-Clause","scripts":{"test":"mocha -u mocha-qunit-ui dist/es5/uri.all.js tests/tests.js","build":"npm run build:esnext && npm run build:es5 && npm run build:es5:min","clean":"rm -rf dist","build:es5":"rollup -c && cp dist/esnext/uri.d.ts dist/es5/uri.all.d.ts && npm run build:es5:fix-sourcemap","build:esnext":"tsc","build:es5:min":"uglifyjs dist/es5/uri.all.js --support-ie8 --output dist/es5/uri.all.min.js --in-source-map dist/es5/uri.all.js.map --source-map uri.all.min.js.map --comments --compress --mangle --pure-funcs merge subexp && mv uri.all.min.js.map dist/es5/ && cp dist/es5/uri.all.d.ts dist/es5/uri.all.min.d.ts","build:es5:fix-sourcemap":"sorcery -i dist/es5/uri.all.js"},"_npmUser":{"name":"garycourt","email":"gary.court@gmail.com"},"homepage":"https://github.com/garycourt/uri-js","keywords":["URI","IRI","IDN","URN","UUID","HTTP","HTTPS","WS","WSS","MAILTO","RFC3986","RFC3987","RFC5891","RFC2616","RFC2818","RFC2141","RFC4122","RFC4291","RFC5952","RFC6068","RFC6455","RFC6874"],"repository":{"url":"git+ssh://git@github.com/garycourt/uri-js.git","type":"git"},"_npmVersion":"6.14.6","description":"An RFC 3986/3987 compliant, scheme extendable URI/IRI parsing/validating/resolving library for JavaScript.","directories":{"test":"tests"},"maintainers":[{"name":"garycourt","email":"gary.court@gmail.com"}],"_nodeVersion":"12.18.3","dependencies":{"punycode":"^2.1.0"},"_hasShrinkwrap":false,"devDependencies":{"mocha":"^3.2.0","rollup":"^0.41.6","sorcery":"^0.10.0","babel-cli":"^6.26.0","uglify-js":"^2.8.14","typescript":"^2.8.1","mocha-qunit-ui":"^0.1.3","babel-preset-latest":"^6.24.1","rollup-plugin-babel":"^2.7.1","rollup-plugin-node-resolve":"^2.0.0","babel-plugin-external-helpers":"^6.22.0"},"_npmOperationalInternal":{"tmp":"tmp/uri-js_4.4.0_1598814277489_0.009253203585056324","host":"s3://npm-registry-packages"},"_id":"uri-js@4.4.0","version":"4.4.0"}